why would my touch drop its wifi connection???

Discussion in 'iPod touch' started by Sapphire08, Aug 19, 2009.

  1. Sapphire08 macrumors member

    Sapphire08

    Joined:
    Dec 20, 2008
    Location:
    England UK
    #1
    For no reason that I know of today my touch has dropped its wifi connection - it's been working perfectly since day 1 - I don't understand it keeps asking for password again saying it's incorrect when I know it not??

    If I go into settings and switch wifi off, then on again - it sees the network, the tick shows up and if it connects then abotu 2 seconds later the tick dissapears again?? Any ideas anyone please???

    Other wireless stuff in the house is working fine, I've not put any new software on it the last few days. It was plugged into its dock the other morning when we had a powercut but its been fine since until today???? :confused:
     
  2. na1577 macrumors 6502a

    Joined:
    Jan 20, 2008
    #2
    Are you in 3.0? I've been having the same issue.
     
  3. Sapphire08 thread starter macrumors member

    Sapphire08

    Joined:
    Dec 20, 2008
    Location:
    England UK
    #3
    Yes upgraded a few days after it was released - been fine since tho until today?
     
  4. JavaWizKid macrumors 6502a

    Joined:
    Sep 18, 2008
    #4
    My wifi is dodgy on 3.0, not happy! The range is significantly shorter!
     
  5. Austin2048 macrumors 6502

    Austin2048

    Joined:
    Mar 16, 2009
    Location:
    Holmes, Pennsylvania
    #5
    ive had no wifi problems with my 2G iPod touch on 3.0. ive been hearing about a lot of wifi problems on 3.0
     

Share This Page