Wi-Fi calling keeps turning off

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Böhme417, May 22, 2017.

  1. Böhme417 macrumors 6502

    Joined:
    Mar 11, 2009
    #1
    I'm not sure if this is the appropriate forum for this, but...

    I am having an issue where my devices won't keep W-Fi calling enabled. This applies to my watch, iPad, and MBP. (Wi-Fi calling only my iPhone stays enabled.) It'll work a few times, and then it'll stop. For example, I'll initiate a call from my MBP, and it'll indicate it's calling through my iPhone, which it shouldn't be doing. I want it to go straight through Wi-Fi. I periodically have to go back and re-enable Wi-Fi calling.

    Is this iCloud account related or cellular related?
     
  2. LewisChapman macrumors 6502a

    LewisChapman

    Joined:
    Jan 10, 2015
    Location:
    UK
    #2
    Does your carrier definitely support this?

    Here in the UK we can use WiFi calling when the cellular signal is weak in an area that WiFi is available but if we are to place a call using a Mac, iPad or Apple Watch the call is still directed through the phone.
     
  3. neil_cm17 macrumors member

    Joined:
    Oct 26, 2015
    Location:
    United Kingdom
    #3
    I think there are a few carriers which allow you to make a wifi call direct from iCloud connected iOS device so that it is not routed via the phone. I don't think this feature is supported by any of the carriers here in the UK for some reason.
     
  4. Böhme417 thread starter macrumors 6502

    Joined:
    Mar 11, 2009
    #4
    Yes, my carrier (Verizon) started supporting Wi-Fi calling from all iCloud-connected devices with iOS 10.3. I believe it's the last of the major US carriers to support this. Anyway, when it works, it's great. It definitely reduces the delay in connecting and the lag to the phone. It's just annoying having to constantly re-enable it.
     

Share This Page