Wi-Fi connection timeout - Very Frequent

Discussion in 'Mac mini' started by oneinten, Apr 21, 2013.

  1. oneinten macrumors member

    Joined:
    Mar 16, 2013
    #1
    Hello,

    Just recently my wireless connection on my Mac Mini has been very inconsistent. I have full signal and it's within quite a short range to the router (cable not possible) but it keep dropping, and when I reconnect to the network it connects for a few seconds than I get the error message saying "Network connection timeout"

    Any idea why this would be presenting an issue now? It's been working flawlessly for 2-3 weeks.
     
  2. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #2
    Have you tried deleting the wifi from your preferred networks and then reconnecting (i.e. so you have to re-enter your password and what not)?
     
  3. borostef macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #3
    This happens with my Mac Mini all the time, every few months... The only thing that I have found to fix the problem is changing my WiFi network name or password in the router settings... Then the Mini connects fine, with no problems... Until it happens again, then I have to repeat the procedure...
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Did you get into your router and select a different wireless channel?

    1. Turn off your Mac's wireless card.

    2. With an Ethernet cable connected (from the router to your Mac) and go into the router and change the wireless channel. I say this because someone near you might have selected the same wireless channel as your router and is creating crosstalk.

    Lastly go get the free software scanner iStunmbler Beta and see if your Mac see other wireless routers around you. This way you can choose a channel that is not being used.
     
  5. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #5
    Rather than go to all of that, have you ever just deleted your wifi preferences for wifi? Sounds like the config gets screwed up and deleting it and reading it should fix it.
     
  6. borostef macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #6
    I have tried deleting the WiFi preferences... It helped the first time, but when it happened again it didn't help anymore... I might add that this problem never happens on my MacBook with Snow leopard on it... I really have given up on trying to solve the cause of the issue... I just don't get it... :confused::)
     
  7. BookEmDanno macrumors member

    BookEmDanno

    Joined:
    Nov 9, 2010
    Location:
    State of ~Aloha!~
    #7
    usb 3.0 interference with wifi

    This might be unique to my situation, but when I connected an external drive to one of my USB ports, it somehow interfered with my wifi connection. I had the drive close to my mac mini (less than a foot). When I used a longer USB cable (about 3 feet) and have the external drive farther, that fixed my problem.

    I believe some users also experienced my situation above and their issue were solved with the same solution.

    ~ Mahalo ~
     
  8. COrocket macrumors 6502

    Joined:
    Dec 9, 2012
    #8
    I have also had this issue. My drive is right next to my mini and there are random times where the internet connection slows/stops.
     
  9. oneinten thread starter macrumors member

    Joined:
    Mar 16, 2013
    #9
    Still not sure what's causing this.. It only seems to happen once every few days until I reset my router.. then it works correctly.

    How do I change the wireless frequency?

    I can see one other wireless network in range so I'm hoping it might just be that.
     
  10. dbroncos78087 macrumors regular

    Joined:
    Feb 27, 2013
    Location:
    Northern Virginia
    #10
    I had this happen to me at work today. I got the timeout on each profile but a simple restart fixed it. Fortunately, I did not have to go into any advanced troubleshooting.
     
  11. risk235 macrumors member

    Joined:
    Oct 17, 2011
    #11
    I experienced the same thing. It shows that Im connected to my router but I get no data. I have to turn off wifi and reenable it for my connection to start working again. I have tried numerous suggestions such as changing my router channel or deleting and adding my wifi network.
     
  12. oneinten thread starter macrumors member

    Joined:
    Mar 16, 2013
    #12
    Hello,

    I am still at a loss with this..

    I have to reset my router every time this happens, it seems to do this on my phone also occasionally but not as frequently, every attempt to connect to my existing network I get the "timeout" error on my mac mini, until the router is reset.

    I will try changing the network frequency and creating a new network under a different name. I don't think this is a fault with the mac as my phone also does this? So it's looking like it's the router/settings but I can't work out what it is!
     
  13. oneinten thread starter macrumors member

    Joined:
    Mar 16, 2013
    #13
    Any ideas people?
     
  14. Adz76 macrumors member

    Joined:
    Mar 3, 2011
    Location:
    Dagobah System
    #14
    WiFi

    Do you have any other devices in the house that connect to the network other than the ones you mentioned?

    Just wondered if you had something else that stays connected or if all devices are having the same problem.

    What router do you have? Netgears sometimes can be a bit troublesome, and some other brands seem to have more occasional problems than others especially with Macs since Lion.

    I would recommend checking if the router is running the most up to date firmware. Sometimes this can be the answer as manufacturers tweaked the firmware post Lion release. How old and what model is the device? Is it a combined router and modem?

    Once the firware is confirmed as being up to date , I would do as one of the other posters has suggested and switch the device to a completely seperate WiFi channel with a new SSID and password.( Delete all old info on all problem devices )

    By default most routers all choose a preset channel (channel 1 or 6 I think ), if you live in a fairly poplulated area it's common for there to be 6 or more close networks all running on the same channel which is not good.( Most people reset devices and leave themas standard apart from say passwords and maybe the SSID )

    For good practice you want to ideally choose a channel number 2 away from all the others you can see.This means you have much less interference and a cleaner less cluttered signal within your network. As mentioned, use a free WiFi sniffer to check all the local networks and audit the most common channels in your area.( Do this before the firware update or new setup of the device )

    Based on the fact that you say Snow Leopard does not have a problem, this points to either all other devices ( doubtful ) or the router. Hope this helps let us know how it goes.
     
  15. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #15
    Delete the below folder and restart, all network settings are reset to default.

    /Library/Preferences/SystemConfiguration
     
  16. jhfenton macrumors 6502a

    jhfenton

    Joined:
    Dec 11, 2012
    Location:
    Norwood, Ohio
    #16
    It's not a direct solution to your problem, but I can tell you what I did to improve my upstairs wi-fi reception, which was not great with the Mac mini. I bought a cheap refurbished Cisco router for which there was a working DD-WRT firmware and set it up as a bridge repeater connected to my downstairs primary wi-fi router. My Mac mini and Apple TV in the upstairs treadmill room are connected to the repeater by Ethernet, with their wi-fi turned off. The repeater router keeps a much stronger connection and signal than the Mac mini and Apple TV do on their own.

    As Adz76 said, you should also check your router's firmware to make sure it is up to date. You might also be able to install the DD-WRT firmware and get better results from that.
     
  17. Nightarchaon macrumors 65816

    Nightarchaon

    Joined:
    Sep 1, 2010
    #17
    Welcome to "one of those things that isnt a problem honest" of mac ownership,

    I have had this problem with two macbook pros, two iMacs and a Mac Mini , all connecting to one of two Time Capsules, two different make routers and a single airport extreme...

    Every time i was told that there couldn't possibly be an issue with the hardware, and to do the juggling and resetting of the wifi and change the channels on the router.

    The fix for every Mac thats had this problem, at least for me, was to replace the Internal Wifi card where possible, or switch Ethernet out to a Timecapsule set up to bridge to an airport connected to the router or to use an external USB wifi dongle.

    Try a wifi dongle, if you dont get any drop-outs, take it to apple if your under warranty or apple care and get the airport card replaced.
     
  18. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #18
    "I have to reset my router every time this happens, it seems to do this on my phone also occasionally but not as frequently, every attempt to connect to my existing network I get the "timeout" error on my mac mini, until the router is reset."

    It may be the router, not the Mini.

    I recently had a similar problem, while connecting to the wireless system at a nursing/extended care facility.

    I was using a MacBook Pro, not a Mini, but what happened was -- I could connect, and everthing was fine, then after a few minutes, no connection anymore.

    If I went to the Network pref pane, and requested to "renew my DHCP lease", the connection would come alive again.

    But then, after a short period of time, the problem would recur.

    Next time this happens to you, instead of resetting the router, try the "renew DHCP lease" trick. Does the connection refreshen?

    This isn't "the solution" (because I didn't find out what "the problem" was) -- only a workaround….

    Final thought:
    How far is the Mini from the router?
    Is it possible to run an ethernet cable between them?
    That almost certainly will fix the problem!
     
  19. oneinten thread starter macrumors member

    Joined:
    Mar 16, 2013
    #19
    I need to find the solution to this..

    In my router settings, I have two wireless frequencies available:

    2.4GHz b/g/n
    and
    5GHz a/n

    Which network should I be using? I can't see any other settings I could really change to make a difference.. and I can't for the life of me work out why my mac mini doesn't like staying connected.

    It's in full range to the router, it's literally above the same the floor in a small house! I can't cable it otherwise that would have been my first thought haha.
     
  20. COrocket macrumors 6502

    Joined:
    Dec 9, 2012
    #20

Share This Page