Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Wi-fi doesn't automatically connect after sleep

Snookerman

macrumors 6502
Original poster
Jul 6, 2008
391
9
After installing Lion, I've noticed that when I open the lid and my MBP goes back from sleep, the wi-fi doesn't always automatically connect to my Airport Express. I then have to click the wi-fi icon and select my network and then it will connect after about 5 seconds. I've searched around and found many wi-fi issues with lion, but they seem more serious. Does anyone know how to solve my less serious problem? Thanks!
 

cmChimera

macrumors 68040
Feb 12, 2010
3,989
2,865
Delete the wi-fi network from network preferences, and delete anything about it in your keychain. It will fix the problem when you connect again. This worked for me at least.
 
Comment

RolandNights

macrumors 6502a
Aug 8, 2011
549
0
California
For some reason, after I started using other networks on a regular basis (school resumed, so I'm regularly on the school's wi-fi and Starbucks' wi-fi networks), this issue has stopped happening to me. Well, it happens once in awhile, but very rarely and it isn't tedious to take care of like it was before.
 
Comment

Snookerman

macrumors 6502
Original poster
Jul 6, 2008
391
9
All of the laptops I've seen with this issue after 10.7.1 have had the Atheros AR5008 in them.
What is that and how do I know if I have it?
Delete the wi-fi network from network preferences, and delete anything about it in your keychain. It will fix the problem when you connect again. This worked for me at least.
Thanks, will try that!
 
Comment

floridabrits

macrumors newbie
May 5, 2011
8
0
Solution that worked for me...

I have a friend who has had this problem since upgrading to Lion on a Macbook (with a Broadcom chipset) and this is what I did to resolve it for her.

Not guaranteeing this works for everyone, but it worked for us...

1. Open KeyChain scripting app (in Applications/Utilities) and delete any entries related to wifi connections.

2. Open Network Preferences and delete all existing WiFi connections completely.

3. Shutdown the Mac.

4. Power on while holding Command, Option/Alt, P and R keys (PRAM reset). Wait until you have heard 3 restart sounds then let go of the keys and let the Mac boot up.

5. After booting, set-up your WiFi connection again (you may have to re-enter the password so make sure you have it).

After doing the above 5 steps my friends Macbook now connects perfectly to the wireless every time... I am convinced there was some kind of corruption occurred in the keychain scripting app during the Lion upgrade, but I'm not an expert so will never really know...

Hope this helps. If it doesn't, my apologies, but at least you had something to try and eliminate in your troubleshooting steps.

Regards.

Floridabrits
 
Comment

cmChimera

macrumors 68040
Feb 12, 2010
3,989
2,865
I have a friend who has had this problem since upgrading to Lion on a Macbook (with a Broadcom chipset) and this is what I did to resolve it for her.

Not guaranteeing this works for everyone, but it worked for us...

1. Open KeyChain scripting app (in Applications/Utilities) and delete any entries related to wifi connections.

2. Open Network Preferences and delete all existing WiFi connections completely.

3. Shutdown the Mac.

4. Power on while holding Command, Option/Alt, P and R keys (PRAM reset). Wait until you have heard 3 restart sounds then let go of the keys and let the Mac boot up.

5. After booting, set-up your WiFi connection again (you may have to re-enter the password so make sure you have it).

After doing the above 5 steps my friends Macbook now connects perfectly to the wireless every time... I am convinced there was some kind of corruption occurred in the keychain scripting app during the Lion upgrade, but I'm not an expert so will never really know...

Hope this helps. If it doesn't, my apologies, but at least you had something to try and eliminate in your troubleshooting steps.

Regards.

Floridabrits

I definitely did NOT have to do the PRAM reset....
 
Comment

sellTheWorld

macrumors newbie
Jun 29, 2010
1
0
Sorry for the necro bump, but I feal it is important to tell what worked for me.

I deleted the password for my airport in the keychain access app. I then deleted all the hot spots my computer knew under system prefs -> networks -> wifi -> advanced.

Then I restarted the computer and deleted the PRAM.

Thanks to floridabrit
 
Comment

igoralves

macrumors newbie
May 4, 2013
1
0
I have a friend who has had this problem since upgrading to Lion on a Macbook (with a Broadcom chipset) and this is what I did to resolve it for her.

Not guaranteeing this works for everyone, but it worked for us...

1. Open KeyChain scripting app (in Applications/Utilities) and delete any entries related to wifi connections.

2. Open Network Preferences and delete all existing WiFi connections completely.

3. Shutdown the Mac.

4. Power on while holding Command, Option/Alt, P and R keys (PRAM reset). Wait until you have heard 3 restart sounds then let go of the keys and let the Mac boot up.

5. After booting, set-up your WiFi connection again (you may have to re-enter the password so make sure you have it).

After doing the above 5 steps my friends Macbook now connects perfectly to the wireless every time... I am convinced there was some kind of corruption occurred in the keychain scripting app during the Lion upgrade, but I'm not an expert so will never really know...

Hope this helps. If it doesn't, my apologies, but at least you had something to try and eliminate in your troubleshooting steps.

Regards.

Floridabrits

Now it works, thank u so much! :)
 
Comment

porjes

macrumors newbie
Dec 28, 2010
2
0
Sorry for the necro bump, but I feal it is important to tell what worked for me.

I deleted the password for my airport in the keychain access app. I then deleted all the hot spots my computer knew under system prefs -> networks -> wifi -> advanced.

Then I restarted the computer and deleted the PRAM.

Thanks to floridabrit
Here we are in 2015... I just deleted everything airport-related in the keychain access app, deleted the hot spots, didn't bother with the PRAM... and Yosemite sorted. Thanks!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.