Wi-Fi gets turned off, can't get it back up unless reboot

Discussion in 'Mac OS X Lion (10.7)' started by thorn101, Dec 21, 2012.

  1. thorn101, Dec 21, 2012
    Last edited: Jan 6, 2013

    thorn101 macrumors newbie

    Joined:
    Oct 5, 2011
    #1
    My Wi-Fi connection randomly gets turned off (the menu bar icon turns empty as when you manually turn it off), and I cannot get it turned on unless I reboot.

    When click on the icon and select "turn wi-fi on" from the menu nothing happens.
    I also get this message in the kernel.log

    Code:
    kernel[0]: WLAN adapter PCIE config space was not restored (stateNumber = 2)
    Dec 21 16:53:52: --- last message repeated 28 times ---
    I have mac os x 10.7.5

    Solutions tried:
    • Resetting nvram
    • Resetting SMC
    (I know both of these have nothing to do with wireless, but I was desperate)

    After that didn't do anything, I tried the following.

    • Removed the wireless adapter from the network section in System Preferences
    and deleted the following from /Library/Preferences/SystemConfiguration/:

    • com.apple.airport.preferences.plist
    • com.apple.network.identification.plist
    • com.apple.smb.server.plist
    • NetworkInterfaces.plist
    • preferences.plist

    Nothing...

    This happens frequently when I download something at high speed.
    For example I just tried to download a... Ubuntu iso file with Transmission and the moment the download started going well the wifi breaks.
    I rebooted, fired Transmission back up, 5 minutes pass and again wifi down.

    Can't put my finger on it at which speeds it exactly occurs, but I do suspect it has something do do with that.
    This not only happens with Transmission but also with a news reader (nzbget)

    Other than rebooting, what do I have to do to get this fixed, and why is this happening.

    Please help
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Do you have the problem without transmission, there seems to be a lot of problems with it including kernel panics.
     
  3. thorn101, Dec 21, 2012
    Last edited: Dec 21, 2012

    thorn101 thread starter macrumors newbie

    Joined:
    Oct 5, 2011
    #3
    Yes, I do.
    I also use a news reader (nzbget) to sometimes download large binary files and the same thing occurs.

    Oh btw. this is on a Macbook Pro 17" from late 2008.

    To add to my original post of things tried, the issue persists under the Guest account.
     
  4. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #4
    I believe this has happened with my MacBook before and oddly enough it was with a direct ethernet connection so it might have been a different problem than with yours'. My DNS address wouldn't come up and it couldn't get an IP until I rebooted for some reason. This is going to sound weird, but it might be your router or modem.
     
  5. thorn101 thread starter macrumors newbie

    Joined:
    Oct 5, 2011
    #5
    I have another dual boot laptop with windows 7 and linux Ubuntu 11.10 which I use for work, no problems there.

    Also I started having problems after upgrading to mac os lion, before that no issues (and I haven't changed anything in my router config in the meantime).

    :mad:!!!
    It happened again while I was typing this reply.
    Deleting the plist files I mentioned in my original post seems to have made it worse :eek:
     
  6. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #6
    o_O You mean you didn't put them back after deleting them didn't solve your problem? You should reinstall Lion. Just do it as if you're installing it for the first time. If you have file it will just downgrade you to which ever 10.7.x you have (can always update later) and hopefully that will fix the problem. Your files and everything will remain intact. I've been told that can be done like that to restore missing, broken, or corrupt parts of OS X.
     
  7. thorn101, Dec 22, 2012
    Last edited: Dec 22, 2012

    thorn101 thread starter macrumors newbie

    Joined:
    Oct 5, 2011
    #7
    Ok, this is what I tried so far.
    I didn't have a mac os x lion installer, and since I'm having trouble with my wireless I didn't want to do an internet install.

    So I stopped by the office and picked up a mountain lion installer usb we have lying around (going to the office during the weekends bluh!).

    Upgraded to Mountain Lion and still the same problem:mad:
    Fearing that it might be a hardware issue after all, I installed bootcamp and windows 7.

    When I first booted into windows I had no wireless (no hardware detected) :eek:
    Went into
    Code:
     device manager -> action -> scan for hardware changes
    and windows found the broadcom 802.11n Network Adapter.
    After doing this I had no problems anymore.

    To test the wireless stability I Left my macbook downloading 9GB of linux images with uTorrent each one downloaded at 1.2 MB speed aprox.

    No here's the weird part, when I do make my wireless crash under mac os x, I have to perform the above routine again.

    If I don't boot into mac osx I have no problems under windows.

    This is very weird.....:confused:

    I'm not sure if my hardware is failing and windows is just handling it better or if mac os x is messing with (or itself messed up) the hardware.
     

Share This Page