Wi-Fi Icon

Discussion in 'Apple Watch' started by ToverT, Sep 22, 2015.

  1. ToverT macrumors member

    Joined:
    Apr 17, 2015
    Location:
    La Habra, California
    #1
    It's nice to have this wifi icon now so that you know you are definitely using wifi and not bluetooth. This is from the glances and the little cloud icon has replaced the phone icon when connected to wifi. Kool !!!!!
     

    Attached Files:

  2. FrisbeeK9 macrumors 6502a

    FrisbeeK9

    Joined:
    Jun 26, 2006
    #2
    I'm at work. My iPhone is connected to the wireless network and I have watch right here. How do I connect watch to wireless network?
     
  3. ToverT thread starter macrumors member

    Joined:
    Apr 17, 2015
    Location:
    La Habra, California
    #3
    Turn off the Bluetooth on your iPhone and your watch should switch to wifi automatically. After turning off your bluetooth check you glances like the pic above and you should see the cloud icon indicating that your watch is on the wifi network.
     
  4. jannette macrumors 6502

    Joined:
    Oct 13, 2011
    Location:
    Bishop's Stortford
    #4
    It will only show the wifi icon when your watch is out of blue tooth range of your phone.
     
  5. deany macrumors 68030

    deany

    Joined:
    Sep 16, 2012
    Location:
    North Wales
    #5
    my (limited) experience at home is that it works on an apple 'roaming' network. I have TC and airport express.

    However it didn't work a few months back with Power line adapters.

    So it depends on how your work is extending the wi-fi signal I guess.


    there was a post yesterday and he said you could now leave your phone at home & make a call in the office.

    I think we are a few years away from that yet.

    Hope that is of some help.
     
  6. chrisvanhorn macrumors regular

    chrisvanhorn

    Joined:
    Jun 10, 2009
    Location:
    Kalamazoo, MI
    #6
    FYI... it doesn't connect to 5ghz networks, so any home networks that aren't dual-band will not allow the watch to connect.
     
  7. ToverT thread starter macrumors member

    Joined:
    Apr 17, 2015
    Location:
    La Habra, California
    #7
    Yes, good point thanks. It will also connect to wifi if you turnoff bluetooth even if the iPhone is sitting on your lap, also it will connect if you wander out of bluetooth range.
     
  8. deany macrumors 68030

    deany

    Joined:
    Sep 16, 2012
    Location:
    North Wales
    #8
    yes I cant get landline broadband so this was a 3 g / 4 g Zoom modem I dont think that was the issue for me. It was the Power line adapters.
     
  9. FrisbeeK9 macrumors 6502a

    FrisbeeK9

    Joined:
    Jun 26, 2006
    #9

    Thanks for this.
     
  10. ToverT thread starter macrumors member

    Joined:
    Apr 17, 2015
    Location:
    La Habra, California
    #10
    You are now free to roam around your workplace anywhere the wifi is available without your iPhone.
     
  11. Scott-n-Houston macrumors 6502a

    Joined:
    Apr 27, 2008
    Location:
    Houston (duh)
    #11
    If I anticipate moving out of bluetooth range often, like just working around the home on various tasks, I'll go ahead and turn off BT to force it to go to wi-fi. I find that otherwise, it tries desperately to hold onto the BT connection, so at the times when you're right on the border of its range, it won't function well or at all, and it will not switch to wi-fi very quickly or easily. I wish it was more willing to move to wi-fi than it is. (I have the same issue with wi-fi vs. LTE for data at times too… I'm sure you've experienced that. It's the same concept.)
     
  12. ToverT thread starter macrumors member

    Joined:
    Apr 17, 2015
    Location:
    La Habra, California
    #12
    Scott, I haven't experienced that. If I leave the BT on, as soon as I wander to parts of the property and lose the BT connection it quickly connects to my wifi. When I come back into BT range it swaps back to the Less power consuming BT connection. My wifi router is the Apple Airport Capsule, maybe that helps me, I don't know. But, as you indicated turning off the BT will connect to your wifi, it just won't auto reconnect to BT when you return to BT range....but that is a minor issue.
     
  13. deany macrumors 68030

    deany

    Joined:
    Sep 16, 2012
    Location:
    North Wales
    #13
    I might be misunderstanding you but my watch reconnects around the house to iphone on Bluetooth (it gives Bluetooth priority over wi-fi) as long as Bluetooth is switched on.
    But wi-fi extending, iphone & apple watch connecting, only worked for me with apple branded 'routers' etc
     
  14. Scott-n-Houston macrumors 6502a

    Joined:
    Apr 27, 2008
    Location:
    Houston (duh)
    #14
    I have an Airport Extreme (the last generation of the flat version) and it works great on wifi, but yes, it just seems to want to hang onto BT as long as possible, so sometimes I'm in this limbo where neither works well. Maybe it's just my house configuration? It's a decent sized house and I have 2 AE's to cover it.

    It definitely reconnects via BT quickly when I'm in range. The preference for BT over WIFI is almost too strong IMO.
     
  15. Scott-n-Houston macrumors 6502a

    Joined:
    Apr 27, 2008
    Location:
    Houston (duh)
    #15
    I have it working on non-Apple routers at works.

    See my note above. It definitely gives BT priority… almost too much so that it won't switch to wifi when I would really like it to.
     
  16. deany macrumors 68030

    deany

    Joined:
    Sep 16, 2012
    Location:
    North Wales
    #16
    Hi Scott

    yes I have re-read your post and understand now.

    can I ask are your AE's connected wirelessly (or cat 6 daisy chain)?

    As I think the cat 6 daisy chain 'roaming network' with router wireless off, is the way (works for me just a bit of a pain tacking cable to wall outside)

    sounds like the stength and 'overlap' of the wifi AE's network maybe the issue.

    cheers
     
  17. perkedel macrumors 6502a

    perkedel

    Joined:
    Dec 30, 2014
    Location:
    California
    #17
    this doesn't work for me. if i turn off BT, it'll just say disconnected in red.
    i have both 2.4 and 5. i wonder if this has something to do with enterprise authentication that i have.
     
  18. Scott-n-Houston macrumors 6502a

    Joined:
    Apr 27, 2008
    Location:
    Houston (duh)
    #18

    I have the cable router in one closet and have both AE's wired directly to it.
    Each is setup with the same SID and password.

    I cannot remember the settings I have on each… I'll have to look when I get home.
    You may be right about why it's having the issue given the 2 AE's.

    I have the same issue with it wanting to hang on to BT at work too, but it may be the same problem because I'm sure my office wi-fi has multiple routers here too.
     
  19. Scott-n-Houston macrumors 6502a

    Joined:
    Apr 27, 2008
    Location:
    Houston (duh)
    #19
    If they're not allowing P2P communication, it won't work. That's a setting on the router.
     
  20. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #20
    I just wanted to say that I agree with Scott on the Watch's preference for BT over Wifi.

    If I leave my phone in the living room and go into my bedroom with my Watch (maybe 25 feet away with a few walls in between) my Watch will continue to cling to BT... and it won't work well. If I turn off BT on my phone before going into the bedroom then my Watch will work perfectly fine on (the much stronger) Wifi.

    I also agree with comparing it to a slow wifi network vs LTE. There are many times when my phone snags a free wifi network that sucks and it attempts to use that instead of LTE which is much faster... and I have to go turn off Wifi to force its hand.

    For that situation Apple just added the "Wifi Assist" option (on your phone: Settings->Cellular then go to the VERY bottom) to basically prefer using LTE over crappy wifi. We need an option like that on the Watch called "BT Assist" ;-)
     
  21. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #21
    Nice find man. I always wondered if my watch was using Wifi at work when I was out of range.
     
  22. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #22
    It's nice to have of course. Mandatory in my opinion, but it's not totally seamless (which I'm fine with)

    When the watch loses BT either forced by phone shut off or range, it does to "disconnected" and then connects to the wifi it can see. whole process takes about 20 seconds all in, not too bad and will be great for wifi in offices, homes etc., when the phone is charging or just somewhere else..

    What will be interesting to see is if it works somewhere with a true login to wifi, not just an SSID authentication
     
  23. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #23
    You may be interested in what I just posted over here:

    http://forums.macrumors.com/threads/watchos2-wifi-without-an-iphone.1919646/
     
  24. perkedel macrumors 6502a

    perkedel

    Joined:
    Dec 30, 2014
    Location:
    California
    #24
    that's not it, in my case. It's not about P2P, it's about authentication.
    if you have RADIUS-WPA2 Enterprise, the watch will not connect.
    When using WPA2-Personal, the watch will have the cloud icon.
     

Share This Page