Wi-Fi is super slow on 80MHz

Discussion in 'OS X Yosemite (10.10)' started by desmortum, Apr 1, 2015.

  1. desmortum macrumors newbie

    Joined:
    Oct 23, 2012
    Location:
    Kyiv, Ukraine
    #1
    Hey everyone.

    So here's my setup:
    • 100Mbit service via cable
    • D-Link AC1200 DIR-850L wireless router (802.11ac) with latest firmware
    • A Windows 7 PC wired to router
    • iMac 27'' Late 2013 (802.11ac) with Yosemite 10.10.2 and Windows 7 via BootCamp
    • MacBook Pro 15'' Mid 2009 (802.11n) with latest Mavericks and Windows 7 via BootCamp
    • iPhone 6 (802.11ac) with latest iOS 8
    • iPad Air (802.11n) with latest iOS 8

    Here's the situation:

    Everything is in room of 15 square meters. Router runs two separate networks simultaneously for 2.4GHz (on 20MHz width and auto channel) and for 5GHz (on 20/40/80MHz width and auto channel). Every single OS on every single device connects and runs both networks on normal speeds around 60-100MBit. Including iMac in Windows.

    But when it comes to Yosemity... It is okay on 2.4GHz network but for 5GHz after boot I have roughly 1-3Mbit. It's clear that it is Wi-Fi reception since when I try to get to routers web-interface it loads slowly. So it's not about internet. If I switch Wi-Fi off on iMac and then switch it back on nothing changes. But when I switch to 2.4Ghz network on same router and then switch back to 5GHz it gets full speed and works great. Again reboot - again 1-3MBit.

    It's like three meters from router.

    The only solution I found is to set 5GHz network channel width to 20/40MHz instead of 20/40/80MHz. Then it works brilliant. But I don't want to cut by 802.11ac bandwidth with removing 80MHz since I have big plans getting gigabit service.

    So what's up in Yosemite with 80MHz?

    I've trie so far:

    • Contacting apple support
    • Updating software on router
    • Updating OS X
    • Resetting and configuring router using Apples KB article
    • Playing with different router settings I could find including channel-by-channel tests
    • Replacing IO80211Family.kext kernel extension with one from 10.10.1
     
  2. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #2
    Pressing ALT and clicking on the WiFi icon in the menu bar to get the speeds or guessing? What are the speeds with your iPhone 6 when your iMac is experiencing issues? Hard to point the finger purely at Yosemite, but you could give the IO80211Family.kext from OS X 10.10.3 a try and see if it improves things or not.
     
  3. desmortum thread starter macrumors newbie

    Joined:
    Oct 23, 2012
    Location:
    Kyiv, Ukraine
    #3
    Sorry. Forgot to say that I'm testing speed via Speedtest. And I can pretty much feel in browser how slow it is.

    Option+Click shows valid 802.11n 5GHz network in 80MHz usually on 36th channel. Speed in this info varies but when Speedtest shows 3Mbit this info shows around 7Mbit.

    iPhone gets around 80Mbit at the same time.

    Edit:
    That would be amazing if someone can post a link to IO80211Family.kext from OS X 10.10.3. Thanks.
     
  4. desmortum thread starter macrumors newbie

    Joined:
    Oct 23, 2012
    Location:
    Kyiv, Ukraine
    #4
    Thanks a ton for the kext but it didn't help. Same thing after reboot...
     
  5. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #5
    Be worth submitting a bug report with Apple. I've got an Asus RT-AC66U running Tomato but I've no 802.11ac Macs to see if it's a widespread issue.
     
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    Try using a channel other than 36. This is a typical default channel for 5GHz operation, so it tends to be crowded by people who don't change away from the default.

    You'd have to change this on your router. There should be a configuration option to do it. The available channels may vary among router brands and models.

    When I got a 5GHz router I changed its channel (default was 36). I went to channel 44, then to 161, where it's been for a few months now.


    You haven't said anything about your surrounding environment. Are you in a house away from other people? In an apartment or condo? Big city or small? What other wireless LANs are visible from your computer (i.e. what shows up in the list of networks you can try connectin to)?

    If none of your devices requires 2.4GHz, then it might be better to turn it off completely. Your list says they all support 802.11n or ac, so I think you can use 5 GHz only. It could be worth doing just as a test.
     

Share This Page