Wi-fi issue--strange

Discussion in 'iPod touch' started by dellavoce, Jan 31, 2008.

  1. dellavoce macrumors regular

    Oct 14, 2007
    Okay, I have never had a problem with using my touch on my home wi-fi network, but suddenly it won't work at all! It says it's connected, but when I try to look at a web page, it can't locate the server. Installer won't refresh resources, basically, even though it says it's connected, I can't access anything.

    Suggestions? I've tried turning wi-fi off and on. Renewing the lease. Resetting network settings. Help!
  2. Macjames macrumors 6502a

    Dec 12, 2007
    Yorkshire, England
    mine did something similar and it turned out that my touch wont connect to any WEP encripted network and only WPA.

    worth a shot
  3. simie macrumors 6502a


    Aug 26, 2004
    Mine was crashing Safari, I resolved it by resetting my touch.
  4. dajoos macrumors newbie

    Jan 23, 2008
  5. aross99 macrumors 68000


    Dec 17, 2006
    East Lansing, MI
    Assuming your router settings haven't changed at home, have you tried restoring the iPod?

    Is your router locked down by MAC address or anything? Doesn't seem like that would be an issue if it worked before, but you never know...

    Does it work on other WiFi networks and not yours?
  6. TheSpaz macrumors 604


    Jun 20, 2005
    Tap the blue arrow next to your network and tap "Forget Network"

    Then go back and re-select your network. You will have to type the password in again but, it should then work.

Share This Page