Wi-Fi not working after sleep

Discussion in 'OS X El Capitan (10.11)' started by KimHansenDK, Jan 31, 2016.

  1. KimHansenDK macrumors 6502

    Joined:
    Jul 29, 2011
    #1
    I know this issue has been brought up af few times, but I haven't found a fix yet.

    Well, the problem is that Wi-Fi is not working after sleep on my 15" MacBook Pro Retina (Mid 2014). I need to restart the browser in order to get it to work. After that Wi-Fi works fine. I have tried to delete the airport/wifi plist files, changed the DNS and reset PRAM but nothing seems to fix the issue. Also I have tried changing the channel (running 5GHz) on my router.

    Once in a while I also experience that the page will not load (often when I click the homepage button in safari) If I then just click the refresh button it works again.

    Any suggestions?

    Is it software related or could it be hardware?
     
  2. mrthomnas macrumors regular

    Joined:
    Sep 8, 2014
    #2
    Just wanted to let you know I have had this issue also, almost the exact same scenario. This is on my iMac and my wife's new macbook pro. The only thing that has fixed it for me is changing the require password time to 4 hours and then it seems to be fine. This leads me to think something weird is happening with Keychain, because I have messed with ipv6 crap, dhcp leases, dns servers, plst files, and everything that Apple support has suggested with PRAM reset and that SMC reset or whatever it's called.
     
  3. Ulenspiegel macrumors 68030

    Ulenspiegel

    Joined:
    Nov 8, 2014
    Location:
    Land of Flanders and Elsewhere
    #3
    What type of security (WPA, WPA2) do you use?
     
  4. KimHansenDK thread starter macrumors 6502

    Joined:
    Jul 29, 2011
    #4
    Well a combination og resetting PRAM and SMC, deleting and manually setting up the Wi-Fi connection, along with changing channel on my router seems do have done the trick. Now the only issue left is, that sometimes when I press the homepage button in Safari, I get a 'page not found' error, but when I click the reload button, the page is accessed instantly. But that might be a bug in El Capitan?
     
  5. mrthomnas macrumors regular

    Joined:
    Sep 8, 2014
    #5
    WPA2, AES
     

Share This Page