Wi-Fi on my touch... STOPPED WORKING! Help Please!

Discussion in 'iPod touch' started by Joshjosh667, Oct 21, 2008.

  1. Joshjosh667 macrumors newbie

    Joshjosh667

    Joined:
    Oct 21, 2008
    Location:
    Vermont
    #1
    I bought my iPod Touch 2G 32gb and at first it worked fine..., but thats when disaster struck! The Wi-Fi on my iPod was working fine and all was well, but for some unknown reason everything just stopped working! Supposedly I was connected to the internet, but nothing would load and if I waited I got an error message saying that whatever (safari, app store, itunes store) was unavailable. This has been going on for a few days now and I don't think its the router because this problem happened at other locations too. SO... is there a way to fix this or should I use my Warranty I got from Best buy and pick up a new one?
    Personally I would like to skip the returning inconvenience, so please help.
     
  2. Alfie macrumors member

    Joined:
    Feb 22, 2004
    Location:
    South Dakota
    #2
    Sorry if this is too obvious, but have you tried turning off the ipod and turning it back on? Not just pushing the sleep/standby button, but actually turning it off? I lose connections occasionally with my 2G, and turning it off and on usually fixes it. I'm hoping this is a bug that will be fixed with a future update.
     
  3. Sam Yikin macrumors regular

    Joined:
    Oct 28, 2007
    #3
    He tried restarting it multiple times, forgetting the network, rejoining it, etc... It finds the network and supposedly connects to it, but any internet use says its not connected... any help?
     
  4. Alfie macrumors member

    Joined:
    Feb 22, 2004
    Location:
    South Dakota
    #4
    How about these ideas:

    1. Reset the network settings for your iPod touch or iPhone
    ( Settings > General > Reset > Reset Network Settings.)

    2. Factory restore of the ipod
     
  5. Chafka macrumors member

    Joined:
    Aug 29, 2007
    #5
    I had kinda the same problem - turns out I had to renew my lease on the network. Problem was fixed after that.
     
  6. KoolStar macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #6
    Also, this sounds like a DNS server issue. Such that the iPod is not able to resolve the dns. Try enter a public dns such as 4.2.2.2 This is a public DNS that I have to use occasionally on all my wireless devices.
     
  7. RRutter macrumors 6502

    Joined:
    Jan 1, 2008
    Location:
    Austin, TX
    #7
    If restarting, resyncing, etc. did not work, try restoring. If that does not work, download a fresh ipsw and put your iPod into DFU mode and restore with the fresh ipsw. Your ipsw could be broken or something like that - very rare, but it's possible.
     

Share This Page