wi-fi problem with belkin router

Discussion in 'iPhone Tips, Help and Troubleshooting' started by fleeper, Aug 28, 2008.

  1. fleeper macrumors 6502

    Joined:
    Jul 30, 2008
    #1
    Hello,

    I have a belikn router. I can connect to my router only after I unplug my router and then power it up again---my phone will see the network and connect to the network.

    After a while my phone will "see" the network but it will not connect to the network---I have to power off my router again and then i can connect to the network again.

    My phone can connect to other wi-fi networks with no problem.

    Any tips on how to fix this issue?
     
  2. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #2
    Do you use WEP on your router? My friend has a Belkin and I had issues connecting to her router when she was using WEP. She changed to WPA and now my iPhone connects every time.

    Also you may want to change the channel on your router. There might be other devices or routers that are interfering with the signal.
     
  3. ashjamben macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #3
    i was in the waiting room at the dentist the other day and managed to get onto a unprotected wifi network which i presume was a belkin router, as it was named something like 'belkin345'
     
  4. himalayas.fien macrumors newbie

    Joined:
    Aug 21, 2008
    #4
    i have signals at home with belkin ... but i dont have any problems to connect to belkin... i dont think it is problem with belkin ..
     

Share This Page