Wi-Fi problems are driving me up the wall!

Discussion in 'MacBook Air' started by yongren, Jan 23, 2012.

  1. yongren macrumors regular

    Joined:
    Jan 19, 2011
    #1
    Hi all. Running a mid-range 2011 11" MBA with the latest version of Lion. WiFi problems are getting to be unbearable.

    I will preface this by saying that my university's WiFi routers are patchy at best, and that their user-ID system might be causing some interference.

    However, I experience most of the same issues at home too, where the connection is pretty reliable.

    Here is what I'm seeing:

    • Lion doesn't remember my preferred networks. Whenever I have to reconnect to WiFi, for whatever reason, it gives me the same dialog, "none of your preferred networks are available." Then I have to pick the network from the list, even if it's the only one there, and even if it's the same network I've been using practically every time I use my computer.
    • I never have a working WiFi connection when I open my laptop. Doesn't matter if it's only been closed for 5 minutes for a walk from one room to another, my WiFi connection never survives. It may be just my imagination, but it seems like several weeks ago this only happened some of the time. Now it is virtually guaranteed.
    • Occasionally, WiFi just drops, out of the blue, while I'm browsing. I click a link and it starts to load but never finishes. The connection appears to be strong, but it just doesn't work.
    • Usually I reconnect to the network by clicking "Turn Wi-Fi Off" in the menubar. But when this doesn't work, my backup method is to go to Network Preferences and manually reset the IP address. However, sometimes everything in this pane is mysteriously greyed out. I can't reset the IP, turning off WiFi does nothing, and my only option is to log out and/or reboot.

    I have tolerated this for practically the entire ~6 months I've had this laptop. Occasionally, when it was particularly annoying, I would try to find a fix online. I've tried everything I could find on multiple occasions. Maybe it's been getting worse lately, or maybe it's just my imagination, but these issues are totally driving me nuts.

    I was more understanding a few months ago, when the computer was brand new and Lion was still just getting started as well. I don't know what the problem is exactly, but I'm assuming it's related to Lion and/or the new MBA hardware... Apple has had more than enough time to come out with a fix. I don't remember ever being this frustrated with a Mac before.

    If anyone has any ideas please enlighten me.

    EDIT: Added a screencap of the greyed-out Network Preferences menu. Has anyone else seen anything like this?
     

    Attached Files:

  2. FrankHahn macrumors 6502a

    Joined:
    May 17, 2011
    #2
    Go to :apple:->System Preferences->Network and perform some settings (especially, set WiFi location as automatic). This may help.
     
  3. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #3
    if you know you schools dns # try writing them into dns setting...or you could try using googles dns servers (8.8.8.8 and 8.8.4.4) and writing them into dns section
     
  4. yongren thread starter macrumors regular

    Joined:
    Jan 19, 2011
    #4
    No luck. Location was already set as automatic. I also tried the Google DNS thing but to no avail.

    Thanks for trying, though, I guess...

    Does nobody else have as bad a problem with this?
     
  5. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
    #5
    Yeah i have the same issue, the only thing that makes it happen less is turning off bluetooth. I tried making a new location in network preferences which is also meant to help but it did nothing for me. :( I think it is a Lion issue.
     
  6. Naasief macrumors newbie

    Joined:
    Sep 27, 2010
    #6
    I have similar issues with wifi droppin or lasting for no more than 1 min. I have Win 7 in boot camp and when I use the wifi there to browse - i have no problems. So to my mind the prob might be with Lion but I also had the problem with SL. But although my router works perfectly with all my other devices - I think it's part of the problem. But a fix wud be nice instead of replacing my router. Advice anyone.
     
  7. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
    #7
  8. Sythas macrumors 6502a

    Sythas

    Joined:
    Oct 22, 2009
    Location:
    Québec, Canada
    #8
    I have a 13" MBA with lion, a imac with leopard and the apple extreme router... it's only my MBA that have the trouble and only when I'm in Lion, win 7 no problem at all...

    It's a problem with Lion ( I had the same trouble with panther) and it's driving me nuts too. I open the laptop, wait 10 sec and choose the network from the list and everything's fine... I use a wpa2 protection on my router.
     
  9. LordVic Suspended

    Joined:
    Sep 7, 2011
    Location:
    Ontario
    #9
    Was having the same problme with Lion on my MBA.
    No matter what it wouldn't reconnect where i expected it to. would often try connecting first to the lowest signal router. Or poop up and say unable to connect to my preffered networks (even in the same room as the router!).

    What i did, was go through my MBA's network configurations, removed every single entry, then started from scratch.

    Works fine now
     
  10. Sythas macrumors 6502a

    Sythas

    Joined:
    Oct 22, 2009
    Location:
    Québec, Canada
    #10
    Wow... thx for the info.... I disabled my bluetooth and BAM... now every time I open my mba I have my network working...

    :eek::eek::eek::D:D:D
     
  11. NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #11
    I had a lot of trouble on my (now sold) 2011 Airs as far as wifi dropouts and poor connection speeds were concerned. My iMac, also on Lion at the time, worked without issue. And my current MBP works great.

    It's pretty annoying that such a phenomenal little computer was let down by something so elementary.

    Incidentally, I've found choosing a lower wifi broadcast channel within the router settings can get around the Bluetooth interference issue. Not sure whether this is possible on your college network though.
     
  12. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
    #12
    Ok guys after much reading on the net i have a proper solution!!!

    Click on the wifi icon at the top,
    go to open network preferences,
    Then click on the little drop down menu next to the + and - button and select "Set service order" and move wifi so it is above bluetooth DUN.

    That's it, problem fixed. :D This prioritizes the wifi connection so when you first wake the laptop the first thing it does is connect to the wifi network rather then trying to connect to bluetooth devices right away.
     
  13. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #13
    so thats why BT f's up wifi connections???? How stupid!!! Thanks for the tip!!
     
  14. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #14
    service order did not work for me. tried that months ago, and BT is off on top of that. I have a thread on here regarding the same issues.

    I'm hoping that 10.7.3 is my salvation. If Apple ever chooses to drop that on us.
     
  15. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
    #15
    I read your thread and you only mentioned changing the network preference order not the service order, though if you are not using BT then i don't think it would be your issue anyway. I don't think 10.7.3 fixes it as someone has already tried it on the Developers seed and the issue still persists. A combination of creating a new network location and re ordering my wifi priority has fixed mine completely.

    Have you tried creating a new network location?
    Also have you tried a 2.4ghz channel rather then the 5ghz range?
     
  16. xenitassos macrumors newbie

    Joined:
    Jan 27, 2012
    #16
    Simply Unacceptable...

    I have a 2011 iMac and while I was on Snow Leopard I had no issues at all. After upgrading to Lion I noticed an unstable connection and wi-fi drops. It wasn't so dense at the beginning but at the last two months it has become unbearable. This is something I would never expect from Apple. I'm pissed and dissapointed. I ended up using ethernet.
     
  17. mrzeigler, Jan 28, 2012
    Last edited: Jan 28, 2012

    mrzeigler macrumors regular

    Joined:
    Oct 15, 2005
    Location:
    Pittsburgh
    #17
    UPDATE: I did what I listed below — sans the extra ethernet cable, which I'm now heading out to buy — and it has worked. Certainly, it won't help people with portable machines with Lion, but in my case it's a pretty good fit since only my desktop, which is next to my cable modem, is running Lion. Is it ideal? No, but all of the internet devices in my household will be able to get on the internet, which was my goal.


    I'm going to spend the day trying and retrying the various potential solutions that have been mentioned for this problem.

    One thing I'm wondering ...

    * This problem appeared when I upgraded my 2011 iMac to Lion
    * I have an older iMac and a Macbook with Leopard and an iPad2.

    So ...

    If I get another ethernet cable and jack my Lion iMac into my cable modem and never use wifi with this machine ... and then configure my Airport Extreme through the old iMac, would this likely be a viable work-around?

    Certainly it wouldn't be ideal (really it would be an inconvenience only with wireless printing from the new iMac, which I rarely do), but -- if this would work -- it would give my new iMac faster internet speeds and restore wireless to the portable devices.

    Would this work? (I don't have an extra ethernet cable to find out right now.)
     
  18. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #18
    I have erase and installed the machine. I have tried new locations. I have the same issue with 2.4 or 5. Whats really f'd is that prior to switching to my 2011 airport extreme dual band, my 2009 airport extreme dual band didn't have this issue with my Air at all. Not once. Literally the day I got the newer router I had the issue.
     
  19. supersalo macrumors 6502

    supersalo

    Joined:
    May 14, 2010
    #19
    Try opening 'Console' and copying/pasting the output from 'All Messages' (starting as far back as when the computer wakes from sleep)
     
  20. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #20
    Either turn off bluetooth or set wifi as your preferred connection.
     
  21. calvol macrumors 6502a

    Joined:
    Feb 3, 2011
    #21
    BT interference seems to worse in marginal signal conditions, sucjh as the library, and probably some router brands. Easiest solution, just turn off BT.
     
  22. bdubya5 macrumors newbie

    Joined:
    Jan 22, 2013
    #22
    Problem Fixed!

    I started having problems when I upgraded my router to a linksys N router. My mac mini could never seem to find the router even though my iphone had no problems.

    I figured out the my internal wireless card does not support the N mode. go to Apple Menu/About This Mac/More Info/Airport and listed under Interfaces you will see "Supported PHY Modes:" . mine says: 802.11 a/b/g so wireless G is the highest mode I can go.

    I went into the Linksys and limited the 2.4GHZ signal to B/G only. and it fixed the problem! Alternatively, you will need to replace you wireless card, but I am o.k. using wireless g for now. There is no perceived speed degradation.
     
  23. nick_elt macrumors 68000

    nick_elt

    Joined:
    Oct 28, 2011
    #23
    What worked for me was changing the router channels from auto to 11. Obviously this can only be done if u have admin access like at home, reading up there are alot of wifi issues with the mac air...
     

Share This Page