Wi-Fi Problems (Late 2008 iMac).

Discussion in 'iMac' started by justinomg, Mar 8, 2009.

  1. justinomg macrumors member

    Joined:
    Sep 12, 2008
    #1
    Hi. There seem to be a problem with my iMac (Late 2008). Ever since purchased the internet connect through Wi-Fi from my router or whatever downstairs has worked perfectly. Since yesterday evening it has suddenly stopped functioning. AirPort still successfully scans for other networks, and every now and then my one appears, but when I try to connect it either says Connection Timeout or Invalid password (when I know it's correct!).

    Also, my iPhone and other laptop and PC are all connected and working fine, leading me to think it's something related to the Mac. I don't know. Any help is appreciated. Thanks.
     
  2. MacGeekPro macrumors newbie

    Joined:
    Mar 8, 2009
    Location:
    Canada
    #2
    Well I have the same iMac and had a similar problem. I bought an Airport Express from Apple and it was fixed up, Could you describe a bit more whats happening? And what type of router are you using? B, G, or N type?
     
  3. justinomg thread starter macrumors member

    Joined:
    Sep 12, 2008
    #3
    It's an older generation BtHomeHub (pretty rubbish anyway). Err, I got it to connect for a few seconds a couple of minutes ago but then it instanty disconnected again - the laptop, PC and iPhone are fine though.
     
  4. MacGeekPro macrumors newbie

    Joined:
    Mar 8, 2009
    Location:
    Canada
    #4
    Well I'm assuming you have restarted? Disconnect and reconnect your router and if that doesn't work I'd get a wifi scanning app, find the router, click on it then open Airport and see if it connects.

    Yoshi
     

Share This Page