WI FI revert to 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iphone666, Oct 14, 2008.

  1. iphone666 macrumors newbie

    Joined:
    Oct 14, 2008
    #1
    Before I moved onto an iphone data plan, i didn't use 3G, and my Wi Fi was perfect. Yesterday, I used 3G and wifi, it was perfect. Today, Wi Fi not working.

    my iphone keeps reverting back to 3G when I have activitated WI FI when surfing websites. I have looked at Apple support site and addressed the issues there, but nothing solved.

    "If you're trying to connect to Wi-Fi and it looks like you're connected, but when you access a web page, it goes back to the cellular data network it may be due to a known issue if the wireless router is using MAC Address Filtering and the iPhone MAC address has not been entered into the filter list. This may also occur if the WEP password was entered incorrectly."

    NO. WPA-PSK entered correctly. NO MAC Address filtering active on my wireless modem.

    I have tapped Forget this Network millions of time.

    I don't want to turn off WPA-PSK encryption on wireless router

    I do not have WEP encryption on the wireless router.

    I have resetted Iphone network.

    I have tapped renew lease.

    I am still surfing on 3G when I have Wi FI activated...help please!!

    I tried to deactive 3G by putting a 1 next to 3services in the APN section (cellular network) on iphone, so i can just use wifi purely.
    But now, my wifi is not working at all!
     
  2. bigbill22 macrumors newbie

    Joined:
    Oct 15, 2008
    #2
    Most likely bad wi-fi antenae

    I had the exact same issuses, apple sent me a shipping box and i sent it to them, they replaced the unit and now it works great. Remember that you wont get your original phone back but the one i recieved actually was much better condition than mine, later
    p.s. the whole process only took like 3-4 days
     
  3. hazza.jockel macrumors 6502

    Joined:
    Aug 2, 2008
    Location:
    in a swag
    #3
    this is what happens at my school. I'm not meant to connect to the wi-fi network but i managed to find out the password. Anyway when the phone is not using data i have full bars of wireless. Once i click safari the bars go empty and 3G kicks in. I think it has something to do with the iPhone not being registered or something to the network so it wont let me use the data. Maybe its the same for you?
     

Share This Page