Wi-Fi Suddenly Stopped Working?

Discussion in 'MacBook Pro' started by Vermillion, Jan 16, 2011.

  1. Vermillion, Jan 16, 2011
    Last edited: Jan 16, 2011

    Vermillion macrumors newbie

    Joined:
    Jan 16, 2011
    #1
    Hi guys,

    Last week I purchased a MacBook Pro 17''. Wonderful computer indeed, however, I am having problems with my Wi-Fi.

    My Wi-Fi was working like a charm last week until today. I bought this computer in Orlando if it matters, used it in my hotel there, and now I am in Miami, using it and connecting to a wireless network in another hotel. I am not sure if it matters because in both places my Wi-Fi has worked wonderfully, until today. It just stopped working altogether. I'm sure the hardware itself works, because it can still deliver the plethora of networks available in my hotel and I can attempt to connect to them. When I try to connect to one of them, the Wi-Fi has an animation, then it shows full bars, then one second after it shows me the Wi-Fi icon with an exclamation (!) symbol. My hotel provides different networks called "SpeedLinkX" (where "X" is a random number). I can't connect to any of them right now, although I could yesterday and the day before. I have googled for a couple of hours now with no luck. The change location trick didn't work for me. What else can I try? Like I said, it randomly stopped working, I haven't touched anything in my settings that could possibly kill my working setting out of nowhere, and when I connect with my iPod Touch, it works like a charm.

    Oh, also, I am pretty new to Macs, so I will need instructions you would give to a "Dummy" for me to fix my issue. I feel shame for asking this since I am a computer geek and even a programmer but I have never used a Mac before haha.

    EDIT: I have noticed sometimes it says that the connection timed out.
    EDIT 2: Forgot an important detail. This hotel's connections are note encrypted, so it doesn't prompt for a WPA or WEP key, but it has one of those "Login" pages where you need to get the info from the provider.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    How do you connect to the internet now?
    And can it be, that the hotel changed its passwords?
    And has turning the AirPort off and on again helped?
     
  3. Vermillion thread starter macrumors newbie

    Joined:
    Jan 16, 2011
    #3
    Firstly, thanks a bunch for your quick reply.

    Right now I am using the PCs in the lobby of my hotel. I only have one hour thought.
    I don't think they changed anything at all, I called and personally went to the front desk to ask if there were any reported problems and they said everything was working fine. They didn't mention anything changed throughout the afternoon.
    Yeah, I tried turning Airport on and off a couple of times and it didn't help.
     
  4. alt macrumors regular

    Joined:
    Feb 12, 2008
    Location:
    Bend, Oregon
  5. Vermillion thread starter macrumors newbie

    Joined:
    Jan 16, 2011
    #5
    I was thinking that too but it kinda makes no sense. The fact it worked more than fine in the last two days and that nothing changed (according to them, anyways) in their network kinda ruled that out. :(
     
  6. RichardBeer macrumors regular

    RichardBeer

    Joined:
    Jul 11, 2009
    Location:
    England
    #6
    If it's an exclamation mark error like the one I am thinking about then it could be a problem with the wi-fi.

    Particularly if you rule out-

    1) Security
    2) Network problems in the hotel
    3) Positioning
    4) Test on a different network

    The only other procedure I can think of in order to try and narrow things down would be to install a different OS, or boot say Ubuntu from a live CD in the hopes that you can see if the wi-fi works or not. This would provide evidence for or against a hardware issue. But this doesn't seem practical considering your position.

    I'd recommend taking it into an Apple Store. You are still under initial warranty so nothing to fear. Manufacturing defects are covered. A lot of hardware failures generally happen within the initial period of purchase.
     
  7. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #7
    I would almost bet that the problem is with the hotel wifi. I have seen problems just like you describe, many times...especially with hotspots that send you to a web page to authorize. The staff at the front desk usually don't have a clue, "everything is working", is a pretty common response. A simple way to prove this would be to take your laptop to a Starbucks or somewhere else that has a hotspot and see if you can get on wifi there.
    Lets us know what you find...
     
  8. Vermillion thread starter macrumors newbie

    Joined:
    Jan 16, 2011
    #8
    Well I didn't have a chance to try it with other connections today but I did something else: I changed the IPv4 address to "Using DHCP with manual address" and used the IP "192.168.0.255". The Wi-Fi icon still has the ! Sign and I still can't connect to the Internet with my Mac, BUT in Network the little ball is green and says "connected". Anything I cando from there?
     
  9. Vermillion thread starter macrumors newbie

    Joined:
    Jan 16, 2011
    #9
    Well my hotel provides DSL cables in some rooms (luckily I have one), so I will use that, and guess I will try to use my Mac at home when I get back home... Though it's wireless only works with iPhones and iPod Touch's for some X or Y reason. If anyone has any other ideas to fix this problem let me know.
     

Share This Page