Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

sn

macrumors 6502
Original poster
Apr 22, 2011
309
37
So I've done all the obvious stuff:

- Updated to iTunes 10.5
- Updated to iOS 5
- Updated to OS X 10.7.2
- Synced my iPhone fully before I tried Wi-Fi Sync
- Selected the "Sync with this iPhone over Wi-Fi" option in iTunes
- Connected iPhone to power

And, when I go to Settings > General > iTunes Wi-Fi Sync on my iPhone, the "Sync Now" button is greyed out and beneath it it says "Sync will resume when "Sushil's Macbook Pro" is available".

Other than this I'm really happy with iOS 5 but this is the only thing that's really bugging me!

Any help would be much appreciated.

Thanks,
Sushil
 

bwhinnen

macrumors 6502
Apr 15, 2010
302
53
McKinney
Yeah, you gotta be plugged into power, either a charger or into the computer to WiFi sync.

Only for automatic sync. You can manually kick off a sync if not connected to power over wifi. Both our iPhone 4's do it fine, to a PC running windows of all things :)
 

btbrossard

macrumors 6502a
Oct 25, 2008
973
11
Chicagoland
Plug your iOS device into your computer with the USB cable.

In iTunes, check the "Sync this device over wifi" button.

Apply.


After that, you should be able to sync over wifi, either manually or automatically when the power is plugged in.


EDIT - That's what worked for me. I see you tried that. Sorry.

What sort of wifi router are you using? Any firewall turned on there?
 
Last edited:

Surely

Guest
Oct 27, 2007
15,042
11
Los Angeles, CA
If you have a dual-band router, you have to make sure both devices are on the same band.

I was having wifi sync issues, but I figured out that is was because my Mini is on the 'n' band and my iP4 is on the 'g' band. Once I switched my Mini over to the 'g' band, it synced.


Scratch that. Now it seems to be wifi syncing without issue with my Mini on 'n' and my iPhone on 'g'.

How strange.:confused:
 

TheVoski

macrumors newbie
Mar 31, 2010
12
1
I was having the same exact problem then I just restarted computer and iPhone, after I tried everything under the sun to get it to work, and it magically worked.

Only problem I have now is I can't get the Automatic Downloads to work when I download podcasts. Any idea?
 
  • Like
Reactions: Staric

batting1000

macrumors 604
Sep 4, 2011
7,451
1,840
Florida
Nope, you gotta plug in your device atleast once before you can sync without being plugged in. You gotta redo this each time you either restart your iPhone, disconnect from WiFi, restart computer, etc. I am not able to sync unless I've plugged in my iPod touch at least once.
 

NorfolkMustard

macrumors regular
Oct 7, 2007
223
0
UK
I was having the same exact problem then I just restarted computer and iPhone, after I tried everything under the sun to get it to work, and it magically worked.

Only problem I have now is I can't get the Automatic Downloads to work when I download podcasts. Any idea?

Auto download (I guess you mean "iTunes in the Cloud" where it auto downloads iTunes stuff to other devices) only works for purchased content.
 

Attachments

  • Untitled.png
    Untitled.png
    37.2 KB · Views: 661
Last edited:

stevnjay

macrumors newbie
Oct 5, 2011
5
0
I have done the exact same as th OP, only difference is ive a pc running win7 64 bit. Nothing I've tried has worked. I've been on so many forums trying to find a solution but I've found nothing that has worked!
Any help would be sweet.
 

batting1000

macrumors 604
Sep 4, 2011
7,451
1,840
Florida
auto download (I guess you mean where it auto downloads iTunes stuff to other devices) only works for purchased content.

No, it works for free stuff too. Auto downloads works on free apps for me, as well as paid apps.

In addition, I think auto downloads is only for music, books, and apps, not podcasts.
 

sn

macrumors 6502
Original poster
Apr 22, 2011
309
37
Plug your iOS device into your computer with the USB cable.

In iTunes, check the "Sync this device over wifi" button.

Apply.


After that, you should be able to sync over wifi, either manually or automatically when the power is plugged in.


EDIT - That's what worked for me. I see you tried that. Sorry.

What sort of wifi router are you using? Any firewall turned on there?

Virgin Super Hub and no firewall... hadn't though of that though so thanks anyway.

If you have a dual-band router, you have to make sure both devices are on the same band.

I was having wifi sync issues, but I figured out that is was because my Mini is on the 'n' band and my iP4 is on the 'g' band. Once I switched my Mini over to the 'g' band, it synced.


Scratch that. Now it seems to be wifi syncing without issue with my Mini on 'n' and my iPhone on 'g'.

How strange.:confused:

Nah, pretty sure mine's not dual-band. Well confused.

I was having the same exact problem then I just restarted computer and iPhone, after I tried everything under the sun to get it to work, and it magically worked.

Only problem I have now is I can't get the Automatic Downloads to work when I download podcasts. Any idea?

Ahah, will try this and let you know, thank you...
 

sn

macrumors 6502
Original poster
Apr 22, 2011
309
37
I was having the same exact problem then I just restarted computer and iPhone, after I tried everything under the sun to get it to work, and it magically worked.

Tried and it still didn't work! Thanks for the suggestion though.

Have you tried it the other way around - i.e. tried initiating the wireless sync in iTunes

How do I do this? Don't tell me the iPhone is meant to be showing up in the source menu because it aint!

----------

Here is as tutorial on setting up your touch for WiFi Sync.

http://www.cultofmac.com/123032/how-to-set-up-wi-fi-sync-with-itunes-10-5-and-ios-5-how-to/

The setup not intuative, but simple once you learn the steps.

I appreciate the gesture but I have explained all the things I have tried in my original post and this article doesn't suggest anything else. Thanks anyway though.
 

TheVoski

macrumors newbie
Mar 31, 2010
12
1
Well, I downloaded a free app on my PC and it started instantly downloading on my iPhone. Did that with a podcast, no go. And podcasts are really the only thing I download on my PC too. That was a let down.
 

sn

macrumors 6502
Original poster
Apr 22, 2011
309
37
probably not particularly enlightening...

...but here's a screenshot of what i mean.
 

Attachments

  • photo.PNG
    photo.PNG
    138.3 KB · Views: 1,105

miKe.Tomb

macrumors newbie
Oct 13, 2011
18
0
To the OP:
I have had the exact same issue today. Yesturday after installing iOS5 it worked flawlessly. Went to work and got home. Tried it and i was getting the same "waiting for so and so to be available again". Plugged it into the pc and it showed up fine with the option "sync over wi-fi" enabled.

After reading your post i decided to plug my phone in again and noticed that iTunes had unselected the "sync over wi-fi" option. I enabled it. Disabled it. Synced. Re-enabled it again. Synced. Unplugged and i'm still "waiting for so and so to be available".

In my router settings i verified that my wi-fi iphone address is still the same and added to my mac filtering. So in the time since yesturday going to work and getting home something has gone wrong. Checked my firewall settings and iTunes is enabled for all traffic just like yesturday.

Conclusion: Due to plugging in my phone and randomly seeing the "sync with wi-fi" option unselected without me ever doing it leads me to believe that its an internal iTunes bug and not the device itself.

This is annoying though because it needs to corrected. Any help for us would be greatly appreciated!
 

sn

macrumors 6502
Original poster
Apr 22, 2011
309
37
Conclusion: Due to plugging in my phone and randomly seeing the "sync with wi-fi" option unselected without me ever doing it leads me to believe that its an internal iTunes bug and not the device itself.

This is annoying though because it needs to corrected. Any help for us would be greatly appreciated!

Starting to think the same thing to be honest. If this is the case, i hope it's fixed soon.

MacBook Pro, WHEN WILL YOU BE AVAILABLE!?!
 

DVDxR

macrumors regular
Jun 18, 2009
179
27
Nope, you gotta plug in your device atleast once before you can sync without being plugged in. You gotta redo this each time you either restart your iPhone, disconnect from WiFi, restart computer, etc. I am not able to sync unless I've plugged in my iPod touch at least once.

One other condition I ran into today and it's annoying: I sync with my home PC but I have iTunes on my laptop for the tethering driver (can't always use WiFi, long story). Last night my home machine showed up in the sync option. I tethered my laptop today (nothing else, just tethered). Get home, go to sync and it is showing my laptop now. Had to connect it to my PC and get iTunes to talk to the phone for a moment (transfer purchases in this case) before it would switch back.

BTW I didn't see it called out specifically in the thread so far, so I'll mention it: iTunes does need to be running (at least on windows) at the time for the sync to work. Appears they didn't use a service for this.
 

miKe.Tomb

macrumors newbie
Oct 13, 2011
18
0
Perhaps if you could try completely uninstalling iTunes and reinstalling. I'm at work but I'll check on the progress. BTW posters it's really hard to take any of you seriously when you refuse to read the OP and reply with things that have been done. If you are going to take the time to reply stupid advice at least take the time to read the issue!
 

sn

macrumors 6502
Original poster
Apr 22, 2011
309
37
iTunes has to be open first. Then as soon as you plug your device into power it will automatically sync over wi fi.

BTW I didn't see it called out specifically in the thread so far, so I'll mention it: iTunes does need to be running (at least on windows) at the time for the sync to work. Appears they didn't use a service for this.

Thanks for the suggestion. Unfortunately it has been running when I've been trying. Cheers though.

----------

Perhaps if you could try completely uninstalling iTunes and reinstalling. I'm at work but I'll check on the progress.

Yeah, didn't really want to try that but might be getting to the point where it's worth it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.