Wi-Fi - WEP Issue iPhone 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by LJ4174, Jan 22, 2009.

  1. LJ4174 macrumors newbie

    Joined:
    Jan 22, 2009
    #1
    Hello... So this is my first post here, I did search the forums first, but haven't found my answer, here or anywhere else, I'm hoping someone can help...

    My company uses WEP on our wireless network, in a ware house to work with handheld RF devices. So please don't suggest using WPA or whatever, we use WEP, I can't change it, it's just the way it is. I can't reboot the router, because these are access points, connecting back to a router. All 300+some odd various devices work fine, except my iPhone. These are Intermec access points, running a 'b' networking (802.11).

    I'm a network/IT guy, so I have all the information to get this connected, however no go. We use a 13 charactor password or WEP key, so we are using 128 bit. Actually, it is connected, but won't accept my password, I keep getting an "incorrect password" password error. I've tried hex, I've tried the $ sign preceeding the password, I've tried a combo of both, I've tried quotes around the ascii password and nothing... I can't get the ATT signal in my building so having this wi-fi feature would be invaluable...

    So any help or suggestions would be greatly appreciated...

    Thanks...

    LJ
     
  2. LJ4174 thread starter macrumors newbie

    Joined:
    Jan 22, 2009
  3. zander271 macrumors member

    Joined:
    Jan 20, 2009
    #3
    only way its going to say "incorrect password" is if its the wrong one. I just tested my phone on WEP and it worked just fine. You must be typing it in wrong which is very easy to do on the iphone.
     
  4. LJ4174 thread starter macrumors newbie

    Joined:
    Jan 22, 2009
    #4
    This is not the case... I absolutally am typing this in correct. All networks are not created equal. I appreciate the help, but a statement that says "the only way it's going to say "incorrect password" is if it's the wrong one" isn't helping...

    Thanks...
     
  5. lambo macrumors regular

    Joined:
    Jul 6, 2008
    Location:
    FL
    #5
    I think the maximum limit of characters for a WEP wireless network password on the iPhone is ten; therefore, the iPhone isn't able to connect. Maybe try just entering in the first 10 characters.

    You could also try to "Reset Network Settings" in the Settings.app.
     
  6. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #6
    Have you tried entering the hexadecimal version? That's what I do on my phone (it's only 64-bit WEP though so I've never had to enter a 26 character hex version - in looking at wifi settings though, I'm certainly able to enter a 26 digit code).
     
  7. LJ4174 thread starter macrumors newbie

    Joined:
    Jan 22, 2009
    #7
    Didn't try the 10 thing, but that's the first I've heard that... Hmmmm...

    Tried the reset... No Go...


    Yep, tried hex in caps, lowercase, with a $ preceeding it... Nadda!!!
     
  8. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #8
    You might be looking at an unfixable issue brought about by a crappy WEP implementation. Not all manufacturers correctly implement WEP (yes, even in 2009.) Now whether it's Apple or the AP manufacturer to blame, I can't say -- but it certainly seems like this sort of compatibility issue to me.
     
  9. LJ4174 thread starter macrumors newbie

    Joined:
    Jan 22, 2009
    #9
    Yeah... That's sorta what I'm thinking as well... Which really sucks!!! :(
     
  10. MacTab macrumors newbie

    Joined:
    Jan 30, 2009
    #10
    I've got the same problem

    it's really pissing me off. I got the phone yesterday, and I set up the network at my house, but I cannot get the darn thing to connect. I certainly know the password, since I own the router.

    Only thing I'm not sure of is that there are four WEP transmit keys. It's 64-bit 10 hex WEP, using key 1. I've tried the text version, I've tried the transmit key (btw, it's a Linksys WRT54G router), but it's always "incorrect password" whether ASCII or hex, and I've tried partial entries too. The full password is about 16 chars, but nothing seems to work. I'll try seeing if there's a firmware update for the router, but I'm suspecting that if it's not fixed by now, in my current version, a new one won't be any different (if there is a new one).

    And, no, I don't want to reconfigure the house just for one frickin' phone. We have quite a number of computers and some secondary devices, and WEP is the only thing that makes everything happy (except, apparently, the iPhone).

    If you figure it out, let me know. What kind of router do you run there?
     
  11. MacTab macrumors newbie

    Joined:
    Jan 30, 2009
    #11
    I got it to work!

    I upgraded my router's firmware, and I had to enter the transmit key in hex (didn't work with the cleartext), but it worked. I had to look three times because I didn't believe it.

    Also, this is 64-bit WEP, so you get your choice of four transmit keys (but you only use one); I didn't have to enter the whole thing, just the hex for the one key that we transmit on.

    My router is a version 6 LinkSys WRT54G router, and the firmware is now v1.02.5 build 002, Jan. 9, 2008
     
  12. drbomb macrumors newbie

    Joined:
    Jul 27, 2009
    #12
    same issue with 3gs

    I have pretty much the same situation. It seems to me that there is something wrong with the iphone os because I have no problem with laptops. Also I used this same router with my iphone 3g on 3.0 with no problem. Does anyone know of any settings in the iphone that might be affecting this inability to logon?
     
  13. WickedRabbit macrumors regular

    Joined:
    Feb 17, 2009
    #13
    Please don't listen to this guy at all because he just assumes that Apple's software is flawless. I posted a thread very similar to this a few days ago and after searching the internet iPhone OS 3.0 seems to be the culprit and the iPhone is definitely having issues with staying connected. I get the same error with my home network and it will say incorrect password despite typing it in correctly and it will randomly disconnect and reconnect and say wrong password every goddamn single day .
     
  14. drbomb macrumors newbie

    Joined:
    Jul 27, 2009
    #14
    I agree 100%. Every other device works fine on this access point. The password is 100% correct. I've been all over with Apple support and they act like its a big mystery, though I've seen many people reporting the same problem in other forums. You would think they would try to address something that is clearly a known issue!
     
  15. InternetWizard macrumors newbie

    Joined:
    Dec 5, 2009
    #15
    Problem SOLVED!

    OK, I've solved the problem!

    To get the iPhone to work with a WEP encrypted connection, you need to choose a HEX key which corresponds to ASCII characters.

    For a 40 bit WEP encrypted connection, you need 10 HEX numbers, or 5 pairs. Just choose a key which corresponds to 5 ASCII characters. You can use a HEX to ASCII converter site like http://www.dolcevie.com/js/converter.html.

    Eg. if you choose the key 41:73:63:69:69, you enter the password "Ascii" in your iPhone (running OS 3.x). (Hex 41 is A, Hex 73 is s etc.)

    For a 128 bit key, you need 13 pairs, so you choose a word (or a string of ASCII characters typeable on an iPhone keyboard) consisting of 13 characters and choose the corresponding ASCII codes in your wireless router/access point.

    I hope that explains how to use the iPhone with a WEP enables Wifi network. (It obviously requires a careful choice of HEX key.)
     
  16. jteddymd macrumors newbie

    Joined:
    Dec 15, 2009
    #16
    Can't change pass

    what if we can't change the wifi encryption, does anyone know a fix for the iPhone os?
     

Share This Page