Wierd issue with usb flash drive

Discussion in 'Mac Basics and Help' started by peevies, Aug 23, 2009.

  1. peevies macrumors member

    peevies

    Joined:
    Feb 15, 2006
    Location:
    MA
    #1
    I have an early 2006 intel iMac 2 GHz Intel Core Duo with 4GB RAM running 10.4.11 (Tiger)
    I also have a late 2007 white macBook 2.2 GHz Intel Core 2 Duo with 1 GB RAM running 10.5.8 (Leopard)
    I have installed all the latest software updates from Apple. I have been using several different capacity Kingston DataTraveler USB 2.0 DTI flash drives with no issues. I just got 2 new 16GB drives from Amazon (all are 1st generation style from Amazon). Neither one will mount on desktop of the iMac, but will work fine on the macBook. They have also been tested on a cousin's 2007 iMac.
    I have restarted, shutdown, tried other USB 2.0 ports, used my USB extension cable.....nothing opens it up on the iMac. It does not show in Disc Utility, however, as I was wiggling the flash drive out of the port......it suddenly appeared on the desktop as a volume and in disk utility.
    It appeared 2 more times and blinked briefly when I did the same thing, but only in Disc Utility.
    The other macs show it as a healthy drive. It works on all of them, as well as all my other Datatravelers. Just this one new 16 GB won't mount on the iMac. (My hardware profiler on the iMac did recognize it as being in the USB port too.) Finder prefs are also checked to show items on the desktop.
    I may just use it on the macBook (already put some files on it.) Any ideas out there? I haven't reformatted it yet.......Thanks!
     

    Attached Files:

  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Return the drive immediately and buy something higher-quality. This is a very, very bad sign.
     
  3. peevies thread starter macrumors member

    peevies

    Joined:
    Feb 15, 2006
    Location:
    MA
    #3
    Hahahaha.......maybe THAT's why they got marked down. I don't know about the Kingstons.......I love 'em. It works fine on everything except my iMac. I use a USB extension cable from the back because it's a pain to get at the USB ports in the back. (using wireless keyboard too.)
    It's when I am sliding the flash drive out of the USB cable it sometimes appears in Disc Utility when I have that app open. Disc Utility spins and spins....it seems like the iMac just doesn't like this 16 GB thing. Plugging it directly into the USB port in back does nothing too. Wierd!!!:confused:
     

Share This Page