Wierd problem with Logitech MX620 and Unibody Macbook

Discussion in 'MacBook' started by darienphoenix, Dec 17, 2008.

  1. darienphoenix macrumors member

    Joined:
    Nov 12, 2008
    #1
    I bought a Logitech MX620 the other day to use with my new Macbook, and have had a really wierd, PITA problem.

    At first it simply wouldn't work - I'd plug the USB receiver in (tried both ports), but it it would act like nothing had happened. No detection, and LCC would tell me there were no Logitech devices detected. It worked flawlessly on my Windows XP box.

    Then, with the receiver plugged in, I plugged my Time Machine drive into the USB port next to it, and suddenly the mouse was detected, even though I hadn't done anything. When I removed the drive, the mouse disconnected.

    It's as if the Macbook is only powering up the USB ports when the HDD is connected, and thinks nothing's there when the USB receiver is plugged in.

    Needless to say, this is a ****ing annoying problem. Any ideas?
     
  2. darienphoenix thread starter macrumors member

    Joined:
    Nov 12, 2008
  3. andimaciphone macrumors member

    andimaciphone

    Joined:
    May 9, 2008
    Location:
    Hereford,UK
    #3
    This may help

    I too have just discovered this problem with my unibody macbook.

    It won't read my memory stick from one of the USB ports.

    I did some googling and found this possible solution.

    I will try it tonight when I get home.

    http://discussions.apple.com/thread.jspa?messageID=8450233
     

Share This Page