Wierd WiFi Problem on new rMBP

Discussion in 'MacBook Pro' started by TheDrift-, Aug 6, 2014.

  1. TheDrift-, Aug 6, 2014
    Last edited: Aug 6, 2014

    TheDrift- macrumors 6502a

    TheDrift-

    Joined:
    Mar 8, 2010
    #1
    Wierd WiFi Problem

    I have just upgraded my 2010 MBP to a new retina model :) Wifi on new MBP works fine at home, and can connect to my iphone as a hot spot etc

    But for some reason it wont connect to my work WiFi, my old mac has no problems, nor does my iphone, I can make my iphone forget network, and rejoin to ensure entering password correctly.

    There is no mac address filtering or anything like that on the work WiFi, tried forgetting and rejoining, turning off and on..iphone works perfectly, old mac fine...but new one wont..

    ....I tried apple and they said my mac was fine, and it was probably the work network and that as my new mac uses the latest tecnology it might not be compatable..(hmmm)

    Anyone any ideas?
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    I dunno but did you compare and contrast the advanced network settings on both the old and new Mac?

    Does anyone else at work use a rMBP with whatever OS version you have. I seem to recall wireless issues with 10.9.3... but I think that was the MBA. Which OS version are you using?

    Do you know the brand/model wireless access-point your worksite uses?
     
  3. joeshmo2010 macrumors 6502a

    Joined:
    Jun 25, 2009
    Location:
    Seattle, WA
    #3
    You didn't put Yosemite on your new mac by any chance did you? Because I know there were some issues with WPA2 enterprise networks. Not sure if the latest DP fixed that.
     
  4. TheDrift- thread starter macrumors 6502a

    TheDrift-

    Joined:
    Mar 8, 2010
    #4

    Not had chance to compare settings will do today, running latest OS.

    I need to have internet connection, maybe I should return the mbp and get another and see if that solves the problem!

    If not then, I suppose my only choice is to continue with my older mac, or maybe look at a windows machine (really don't want to have to do that if can be avoided)

    ----------


    Nope I'm on mavericks
     
  5. otom macrumors newbie

    Joined:
    Sep 10, 2014
    #5
    Possibly the same wifi problem on rMBP Mid 2014

    I bought a new rMBPro 13-inch Mid 2014 about 10 days ago and have been struggling with wifi connection (802.11n) at my home.

    Besides the newly bought rMBP, I have a MBAir 11-inch Mid 2012, iPhone5s and Win7 PC, all connected to the same router via 802.11n without any problem. However, the new rMBP is the only machine that cannot be connected to the router. (of course, mac address (aka wifi address) filtering is disabled)

    Here is the symptom.
    The new rMBP does receives SSID of the router and shows it on the screen.
    So, the SSID is selected and its password is typed.
    Then, once the connection button is pressed, the dialog window immediately displays the message "could not be connected". It does not seem sending out the password for auth process.


    After attempting so many trials, it is found that my new rMBP can successfully connect to the router, only if the router is set to use 20MHz band width, but not 40MHz.

    For last few years, 40MHz width of 2.4GHz band for 802.11n has been the stable configuration on my router, and the MBA 11-inch Mid 2012 and iPhone5s had no problem at all with it. (and other WinPCs, android phones, wifi-printer and wifi-scanner, too)

    Only the new rMBP 13-inch Mid 2014 does not work with the setting.

    I do not have a router which is capable of 802.11n on 5GHz band, I could not try out 40MHz vs 20MHz on 5GHz.
    But, it is already obvious enough that the new rMBP is the only machine having the problem, while other Apple machines (MBA and iPhone5s) do the connection of 802.11n, 40MHz width on 2.4GHz band.

    The rMBP will be exchanged at the store this weekend.
     

Share This Page