Wierds startup shutdown issues

Discussion in 'MacBook Air' started by twiggy666, Jan 15, 2012.

  1. twiggy666 macrumors newbie

    Joined:
    Jan 15, 2012
    #1
    I've installed Windows 7 on my 2008 MacBook Air by bootcamp. Worked perfectly for couple of moths. Then this happened:

    *The "power on" led only lights up briefly when turning computer on then goes black
    *Win 7 takes ages to boot. >5 min. But works fine when boot finished. Then takes ages to shutdown. Once displayed bluescreen at shutdown which flashed by to quickly to read but said someting about power driver issue.
    *OSX boots fine, but power on led still wont work properly

    What could cause this? Battery needs to be replaced? Something more serious?
     
  2. KPOM macrumors G5

    Joined:
    Oct 23, 2010
    #2
    Do you have a hard drive or SSD-equipped 2008 Air? If it is the latter, it is possible that the SSD is starting to wear out or has a lot of "garbage" that is slowing the drive. The older SSDs didn't have TRIM or other techniques to maintain drive condition.

    Since the LED isn't lighting up, it is also possible that something is wrong with it. Maybe take it to a Genius Bar where they can run some diagnostics. If everything checks out, you might consider installing a replacement SSD. OWC sells some compatible with older MacBook Airs.
     
  3. twiggy666 thread starter macrumors newbie

    Joined:
    Jan 15, 2012
    #3
    It has an SSD. But it seems to me its something else since that "power on" led thing started at exactly the same time. And also that "blue screen of death" message about some power related issue. Just curious if someone else have had a similar problem.
     

Share This Page