Wifi attempted connection timing out on iMac

Discussion in 'Mac Basics and Help' started by BULLITTO, Nov 29, 2010.

  1. BULLITTO macrumors newbie

    Joined:
    Nov 29, 2010
    #1
    On startup the wifi connection symbol initially is full and black and then goes grey with in a few seconds. If I click the wifi symbol the drop down menu shows my wifi network which I click put in WEP code but then I get a message after a few seconds that the connection has timed out. All other Macs in the house connect to the wifi fine. Any ideas what might be causing this please?
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Two things to start out with testing:

    1) Is the problem computer farther from the router and/or does it have something in between it and the router like a central heating blower or microwave? The symptoms you're describing are pretty much the behavior if the signal is very weak. If you can, try moving it closer and see if it works properly; if so, there's your problem.

    2) Try selecting "Turn Airport Off" from the drop-down Airport menu, then immediately selecting "Turn Airport On". If it then connects automatically and properly, you're seeing a the same problem I've had intermittendly for years--the Mac somehow fails to automatically connect (usually after wake from sleep) until the hardware is toggled off and back on. If this is your issue, I've never found a workaround and have been goofing with it for years. I assume it's a hardware problem.
     

Share This Page