Wifi / Bluetooth / Mavericks bug

Discussion in 'OS X Mavericks (10.9)' started by Riccardo83, Jan 29, 2014.

  1. Riccardo83 macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #1
    Hello guys,

    I have a late 2013 MacBook Pro Retina 15. I have quite a few issues with my first apple product ever.

    Oh well. Heres one:

    a) With Bluetooth enabled, it only takes 2-3 restarts and the Wifi Connection wont reestablish. It tries for like 15 seconds or so and then shows an exclamation mark. Only disable and enable Wifi connection works.

    b) With Bluetooth disabled, no reconnectiong issues even after 10 restarts or wake ups... too bad im using magic mouse and apple keyboard with bluetooth....

    Annoying!
     
  2. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #2
    Try changing the channel of your wireless router.
     
  3. Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #3
    I see no reason why to do so. All other networks seem fine and it clearly has something to do with bluetooth enabled?

    Its late at night now, however I will still give it a try.
     
  4. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #4
    Wi-Fi and Bluetooth interference makes magic mouse jumpy and usually the fix is to switch to 5 GHz or change Wi-Fi channel. Changing channel might also help in your case.
     
  5. Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #5
    You maybe right but I have an airport express connected to my router via Ethernet and not straight to the router? And one would assume apple would make a product that works with its own devices?
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    Is your Macbook wirelessly connected to the Airport Express (AE) or to the router ?

    How is your network set up exactly : do you use both wifi networks (router + AE) or do you use only one ? In that case, did you disable one of the 2 wifi networks ?
    How long is the Ethernet cable between router and AE ?
    I mean are they in the same room or not ?

    Etc…
     
  7. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #7
    I have had more connection issues with my Airport Express than with any other wireless access point ever. I had this same issue for a long time where I had to turn on/off my airport on my MBP several times to get it to finally connect. I had someone come over with a Windoze box and had all kinds of problems getting it to connect. My linux box would never successfully connect to it. I finally got a cisco access point and everything works much better now.
     
  8. Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #8
    I'm connected to the airport express via Wifi. The airport express itself is connected to the router via Ethernet cable which is max 1m. Same room yes.

    ----------

    And btw both Wifi networks are running. I'm using the express one to also use Airplay. My other room mate connects to the router via Wifi itself. But again? Why would disabling Bluetooth solve the issue?
     
  9. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #9
    Did you disable the wifi of your router, if case it's a wireless router ?

    Just seen your edit : could you disable your router wifi and use only the AE wifi ?

    As for Bluetooth and wifi, it's well know that they interfere.
     
  10. Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #10
    No. But I could try but then I'd have to tell my roommate to access the airport express. Did not wanna do that?
     
  11. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #11
    I understand you prefer to keep the 2 wifi networks, right ?
    The AE for you, the router's wifi for your room mate.

    Did you check which channels both access points (router + AE) use ?

    Do you have many other wifi networks around ?
    You can use IStumbler to see all the wifi networks and the channels they use.
     
  12. Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #12
  13. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #13
    Be confident, as many users (like me…) never have any problem with wifi.
    This does not mean that there are no problems, though : some users do have problems with wifi.

    I must say that it's quite mysterious for me, as I never never had any problem with wifi on my Macs, from Leopard to Mavericks, with iMacs, White Macbooks, Macbook Pros.
    I connect my Macs to my home network and to many others networks without issues.

    Some problems with wifi need to delete/reconfigure the network settings (preferences files, keychains), and do some maintenance (permissions).

    Some times (often, actually), changing the wifi channel solves the issue.

    Airport Expresses work very well as routers and as access points.
     
  14. Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #14
    Ok here we go:

    3 Networks:

    Router network: Protocol n, Channel 1, 2412mhz, band 2,4ghz, width 20mhz
    AE Network 1: Protocol a,n ,Channel 100, 5500mhz, 5ghz, 40mhz
    AE Network 2: Protocol b, g, n, Channel 1, 2412mhz, 2,4ghz, 20mhz

    Now I will be trying to restart a few times connecting to the router network. (I will turn AE off during that test)
     
  15. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #15
    Do you have 2 AE's ??

    One is using the same channel as the router, so change either the router's or the AE's channel to channel 6 for instance.
     
  16. Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #16
  17. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #17
    Oh yes sorry, you're right.

    However, your AE's 2,4 GHz network uses the same channel as the router, so you should change it.

    (change either the router's or the AE's channel to channel 6 for instance).
     
  18. Riccardo83, Jan 30, 2014
    Last edited: Jan 30, 2014

    Riccardo83 thread starter macrumors member

    Riccardo83

    Joined:
    Jan 29, 2014
    Location:
    Berlin
    #18
    Ok. Here are the results with my MBP connected to the Routers network and the Airport Express disabled (No Power)

    a) I restarted 10 times and not once the connection took longer than 2-3 seconds to connect to the wifi. I never had to disable and enable Wifi anymore. GREAT!

    (On a side note, when i restarted and I had Mavericks open all current programs / windows after the restart (Chrome for me) they were loaded earlier than the connection was establed and i manually had to refresh Chrome - not a big deal though as I think this is normal behaviour?!)

    b) I will now connect the Airport Express again and change its or the routers Channel.

    ----------

    I just realized, that after connecting my AE again, it did indeed choose channel 11 by itself and the router still remained as channel 1.

    To be safe Ill manually change the AE's channel to 6 anyway and do a few restarts .

    ----------

    Damn. I just restarted a few times with AE's channel set to 6 and router at 1. Out of 5 times I had 4 times no connection and an Exclamation mark. Checking iStumbler and it now shows 3 AE networks? Wtf?

    2 AE at 5ghz at channel 100
    The third AE at channel 6 as I set it to

    What the hell? I can not even edit the airport express 's settings.

    Only after disabling and enabling Wifi works.

    ----------

    After disabling and enabling Wifi, its back to 2 AE Networks. Wifi works. Im clueless....
     

Share This Page