WiFi can connect to internet but ethernet don't

Discussion in 'OS X Mavericks (10.9)' started by [Radium], Jun 11, 2015.

  1. [Radium], Jun 11, 2015
    Last edited: Jun 11, 2015

    [Radium] macrumors newbie

    Joined:
    Jun 11, 2015
    #1
    Hello,
    I just changed my router with a new one.
    It's a D-Link wireless/LAN router.

    The problem is since using the new router, I can connect to internet using WiFi on my phone and MacBook, but ethernet does not work on Mac at all.

    When I open the network settings, it displays the ethernet as connected with a green light, but I cannot open any web-pages or ping at terminal.

    Please help this weird problem is giving me a severe headache.

    IMPORTANT UPDATE:

    I can connect to internet via ethernet on the windows 7 virtual machine running on my MacBook.
    So the problem lies somewhere in OS X configurations and there's nothing wrong with router configs.
     
  2. [Radium] thread starter macrumors newbie

    Joined:
    Jun 11, 2015
  3. ricede, Jun 13, 2015
    Last edited: Jun 13, 2015

    ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #3
    Have you tried creating a new location in system prefs /network.

    You could also try system prefs /network /assist me /diagnostics
     
  4. [Radium] thread starter macrumors newbie

    Joined:
    Jun 11, 2015
    #4
    None of it worked.

    But I removed the Ethernet service from network settings, and created a new one.
    All is fine now and I'm posting here using ethernet,
    Except that I still have problem connecting to Kerio VPN via ethernet, whereas on WiFi I can connect seamlessly.
    That's weird.
    Do you know why that happens?
     

Share This Page