WiFi Connect Problems...

Discussion in 'OS X Mountain Lion (10.8)' started by thinkstopthink, Feb 11, 2013.

  1. thinkstopthink macrumors newbie

    Feb 11, 2013

    I'm working in Thailand and Laos. I have a Mid 2010 15" MBP running 10.8.2 and a 3GS running iOS 6. I'm writing this tethered through my iPhone using up my 3G data way too fast...

    I am having a terrible time getting connected to WiFi. In a very nice French cafe in Bangkok I could not connect; there were, however, several PC users connected fine. This happened in several different establishments. In some cases I could get the iPhone to connect. When I was in Dean and Deluca, also in Bangkok, I connected fine and had blazing speeds.

    Now I'm in a new hotel in Laos and I can't connect to either of the two WiFi networks. My iPhone will not connect either. There is a couple down a few doors. Her iPhone will not connect; his Samsung Android will. Another man was in the courtyard with his Windows notebook, he connected to both networks fine.

    I've done this:

    Deleted all network interfaces and created new ones.
    Deleted all Keychain entries for the networks at this hotel.
    Deleted all preferred networks.
    Created a new wifi network location.
    Created a new admin user and tried to log into the WiFi with that.
    And a couple other things I can't recall right now.

    All of these are unsuccessful. I fired up iStumbler and this is the network data:

    Security: WPA
    Protocol: 802.11n
    Channel: 1
    Frequency: 2412

    My Mac's system information lists the network as this:
    PHY Mode: 802.11n
    BSSID: 64:70:02:c8:a6:44
    Channel: 1,+1
    Country Code: US
    Network Type: Infrastructure
    Security: WPA Personal
    Signal / Noise: -90 dBm / -92 dBm

    Both the networks have simple 8 digit passwords made up of numbers. When I try to connect through Network Preferences, I get two messages, that flip back and forth as the laptop tries to connect:

    1. Wi-Fi does not have an IP address and cannot connect to the Internet.
    2. Wi-Fi is turned on but not connected to a network.

    When I try to log in with the password, I either get a

    3. Connection Timed Out
    4. Invalid Password

    Error displayed depending on which one of #1 or #2 are currently showing.

    I'm at the end of my rope with this. Anyone have any ideas why all the Apple products in the hotel are dead when it come to WiFi and all the 'droid/Windows machines connect without a hitch?

    How can I get connected to the WiFi network?

    Sorry if some of this isn't clear, I've been traveling all day...


  2. thinkstopthink thread starter macrumors newbie

    Feb 11, 2013
    WiFi Connect Problems...


    And now every time I tether my iPhone, I have to restart the MBP for it to use the tethered connection... even though the iPhone shows "Personal Hotspot: 1 Connection."

  3. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    Did you update to 6.1? Is it jailbroken?

    That said my 4 on 6.1 still has IMHO funky WiFi software. Restarting the iPhone or toggling WiFi on it seems to get the hotspot to work. USB hotspot works every time.
  4. thinkstopthink thread starter macrumors newbie

    Feb 11, 2013
    No, it is out of contract so I had it unlocked so I could use it with a local SIM in each country I'm going to be in.

    The phone was jailbroken at one time... and tethering then was flawless!

    I'm just waiting for 10.8.3 and 6.2. Maybe Apple has fired all their current staff on the wifi team and hired all the hackers. Might get functional 'net connectivity again... can you imagine that? What a concept.
  5. Quad5Ny macrumors 6502a


    Sep 13, 2009
    New York, USA
    "Signal / Noise: -90 dBm / -92 dBm" - That's a HORRIBLE signal, the noise is good but the signal is almost non-existent.

    I'm surprised you actually managed to connect at all, are you sure you typed that correctly?
  6. thinkstopthink thread starter macrumors newbie

    Feb 11, 2013
    As I stated in the original post, I didn't ever connect. I copied and pasted it, so yes.

    I can see the low but consistent signal but cannot connect to it. iStumbler gives me 13% signal, 13% noise. I didn't check it in the lobby.

    Strange that a Windows notebook on the other side of this piece of drywall connects fine and gets good speed. And a 'droid two doors down connects fine. An iPhone two doors down won't connect either.



    Just checked again with WiFi Diagnostics:

    Network #1

    Signal -93
    Noise -92

    Network #2

    Signal -68
    Noise -92

    I've tried to connect to both; identical results.

  7. Quad5Ny macrumors 6502a


    Sep 13, 2009
    New York, USA
    I know its not much help with your overall problem, but I would avoid Network #1 (if the readings are accurate). The signal needs to be greater than the noise.

    The farther you get into negative numbers, the lower signal. The signal's signal needs to be higher than the noise's signal. It's the equivalent of having a crowd of people chatting, in order hear a individual speak they need to talk louder than the crowd. This is called Signal to Noise Ratio (SNR).

    (Note for some reason signal readings start out in negative numbers but can move all the way into positive numbers.)
    Noise: -92 dBm
    Signal: -68 dBm
    (-92 minus -68)
    SNR = 24 dB

    I found this some recommended SNR levels by doing a Google search:
    • > 40dB SNR = Excellent signal (5 bars); always associated; lightening fast.
    • 25dB to 40dB SNR = Very good signal (3 - 4 bars); always associated; very fast.
    • 15dB to 25dB SNR = Low signal (2 bars); always associated; usually fast.
    • 10dB - 15dB SNR = very low signal (1 bar); mostly associated; mostly slow.
    • 5dB to 10dB SNR = no signal; not associated; no go.

Share This Page