Wifi connectivity intermittent at best...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jp45678, Mar 2, 2010.

  1. jp45678 macrumors newbie

    Joined:
    Nov 27, 2007
    #1
    I don't know if anyone can help, or are experiencing similar issues, but I have a 3GS and my home network is a d-link 615 running dd-wrt. The iPhone has a static IP and wireless security is wpa-personal. I have used iStumbler and made sure my network is the only one in the area on that channel.

    The issue I am having is that my iPhone, when connected, is very intermittent. Youtube videos will take much longer than the length of the video to load, and I have run speed tests, first on my mac, then my iPhone and my mac is giving me, say, 15Mbps, and my iPhone giving me 0.05Mbps. It has only started happening in the last few weeks, which, thinking back, I believe happened around the time of the 3.1.3 update.

    I have the results of a ping test which shows towards the end 1/3 pings failing, which is the general pattern when I ran it for several minutes.


    PING 192.168.1.141 (192.168.1.141): 56 data bytes
    64 bytes from 192.168.1.141: icmp_seq=0 ttl=64 time=110.829 ms
    64 bytes from 192.168.1.141: icmp_seq=1 ttl=64 time=5.835 ms
    64 bytes from 192.168.1.141: icmp_seq=2 ttl=64 time=7.099 ms
    64 bytes from 192.168.1.141: icmp_seq=3 ttl=64 time=8.796 ms
    64 bytes from 192.168.1.141: icmp_seq=4 ttl=64 time=8.095 ms
    64 bytes from 192.168.1.141: icmp_seq=5 ttl=64 time=6.025 ms
    64 bytes from 192.168.1.141: icmp_seq=6 ttl=64 time=7.804 ms
    64 bytes from 192.168.1.141: icmp_seq=7 ttl=64 time=6.617 ms
    Request timeout for icmp_seq 8
    64 bytes from 192.168.1.141: icmp_seq=9 ttl=64 time=7.321 ms
    64 bytes from 192.168.1.141: icmp_seq=10 ttl=64 time=5.772 ms
    Request timeout for icmp_seq 11
    64 bytes from 192.168.1.141: icmp_seq=12 ttl=64 time=8.537 ms
    64 bytes from 192.168.1.141: icmp_seq=13 ttl=64 time=8.784 ms
    Request timeout for icmp_seq 14
    64 bytes from 192.168.1.141: icmp_seq=15 ttl=64 time=5.308 ms
    64 bytes from 192.168.1.141: icmp_seq=16 ttl=64 time=6.015 ms
    Request timeout for icmp_seq 17
    64 bytes from 192.168.1.141: icmp_seq=18 ttl=64 time=9.388 ms
    64 bytes from 192.168.1.141: icmp_seq=19 ttl=64 time=5.838 ms
    Request timeout for icmp_seq 20
    64 bytes from 192.168.1.141: icmp_seq=21 ttl=64 time=10.657 ms
    64 bytes from 192.168.1.141: icmp_seq=22 ttl=64 time=7.641 ms
    Request timeout for icmp_seq 23
    64 bytes from 192.168.1.141: icmp_seq=24 ttl=64 time=9.103 ms
    64 bytes from 192.168.1.141: icmp_seq=25 ttl=64 time=7.684 ms
    Request timeout for icmp_seq 26
    64 bytes from 192.168.1.141: icmp_seq=27 ttl=64 time=7.268 ms


    Has anyone else had this issue before, are there specific requirements for my router? Why would it drop 1/3 ping requests? (pinging other computers on the network shows no dropouts.)


    Any clues/information/advice would be greatly appreciated
     
  2. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #2
    Have you tried resetting your iphone network settings? I had similar problems after upgrading from 2.2.1 to 3.0 (I am not on 3.1.3 as yet!). Or even a simple reboot may help to rectify your problem!

    I wouldn't touch the router!!
     
  3. jp45678 thread starter macrumors newbie

    Joined:
    Nov 27, 2007
    #3
    Yes, sorry, forgot to mention, I have so far reset network settings and reset the phone several time. I have not yet restored it, but really want to avoid this if possible.

    Did you manage to get yours working correctly when you had similar issues?
     
  4. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #4
    Was ok after a reboot. Only other thing to try is a restore and then set up the iphone as new, this will completely remove all your previous settings.

    It may be possible that it is a hardware fault on the iphone. If your iphone is still under warranty (which i am hoping it is!!) then i would recommend that you return it back to apple at the genius bar. They will either try and fix it or replace it.
     

Share This Page