WiFi disconnects during sleep

Discussion in 'MacBook Pro' started by BulkHedd, Apr 22, 2014.

  1. BulkHedd macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #1
    I recently upgraded my 2010 MBP with a 256GB SSD and did a fresh install of Mavericks. Ever since then when the computer goes to sleep the WiFi is disconnected. I sometimes use TeamViewer when I need to connect to my MBP from work and it usually shows the Mac offline.

    I don't recall this ever happening before I did the upgrade/clean install of OSX.

    I don't really have any WiFi problems during normal use of the the computer.

    I went in the TeamViewer settings and turned on the "Wake on LAN" setting and still nothing. This morning I got to work and tried to connect with TeamViewer and nothing. That was about 30 minutes after making sure everything was up and running on the MBP.

    Does anyone have any ideas or suggestions?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    WIFI always disconnected when you put the computer to sleep, that's not a new phenomenon AFAIK.

    I mean if the computer is asleep everything but ram is powered down (for the most part)

    When my computer is in sleep, I've never been able to log into it via gotomypc.

    Perhaps you only put the monitor to sleep before and now its fully going to sleep.
     
  3. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #3
    Hmmm...Maybe the default OSX setting is to put the computer to sleep but my old setting was just to turn off the screen. I'll have to check that later today.
     
  4. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #4
    if you did a fresh install without restoring anything from a time machine backup then the settings are back to default with the computer going to sleep after awhile.

    also make sure you check system preferences -> energy saver -> power adapter and make sure wake for wifi access is checked
     
  5. BulkHedd thread starter macrumors 6502

    BulkHedd

    Joined:
    Nov 13, 2006
    #5
    FYI, that was it. The energy settings were to go to sleep after 15 minutes. I set it for "never" when plugged in.

    Thanks for the help!
     

Share This Page