Wifi disconnects when sleeping...

Discussion in 'iPod touch' started by sk1des, Sep 17, 2010.

  1. sk1des macrumors newbie

    Sep 17, 2010
    Okay, i know there are a couple of similar threads before this,
    but the ipod i have atm is a brand new ipod touch 4...

    whenever my ipod autolocks after 2 mins, my wifi disconnects when i unlock it. The wifi icon is still there, but my IM apps like beejive and nimbuzz disconnects. Also when i try to load pages in safari, it says 'safari could not open the page because the server stopped responding'
    The only way i could connect back is either to renew lease in network settings or wait for 5 minutes for the IM apps to connect to the wifi again...

    i thought os4.1 says wifi doesnt disconnect when asleep? my push notification is on, and also idle settings for beejive is set at 12 hours. I tried resetting network settings to default but still the same.
    Anyone facing similar problems? anyone knows how to fix this?

    and i dont think theres a problem with the router wifi since my laptop doesnt disconnects then..
  2. sk1des thread starter macrumors newbie

    Sep 17, 2010
    am i the only one with this problem? no one else with a 4g or running os4.1 have this? :confused:
  3. pknz macrumors 68020


    Mar 22, 2005
    I think this is a power saving feature. WiFi does turn off when the device is asleep. Same on the iPhone (and maybe iPad too?).

    Please correct me if I'm wrong.
  4. sk1des thread starter macrumors newbie

    Sep 17, 2010
  5. 4DThinker macrumors 68020

    Mar 15, 2008
    You need to check settings at the WiFi Router you are using. Most can be set to disconnect a device after a defined period of no activity. That may be your culprit.
  6. androiphone macrumors 65816

    Dec 13, 2009
  7. mmpierce macrumors newbie

    Jul 5, 2010
    Just wanted to let you know that you're not alone. Since I updated to 4.1, my 3rd Gen iPod Touch is disconnecting from WiFi when it sleeps/is locked. According to the specs from Apple, persistent WiFi is still a feature, so I'm not sure what changed. It's really frustrating. My husband's 3rd Gen Touch is still running 4.0.2, and isn't having this issue at all. Resetting the router, manually entering the DNS server, and restoring the iPod haven't helped at all. In my case, the update to 4.1 seems to have caused the problem.
  8. forcetactic macrumors 6502

    Jul 30, 2010
    I've had this issue on 4.0.2 and 4.1. Anyone have a solution so that wifi stays persistent even in sleep mode?
  9. mmpierce macrumors newbie

    Jul 5, 2010
    Has anyone found a fix for this? Barring a fix, do we know when 4.2 will be released?

Share This Page