WIFI/external display

Discussion in 'MacBook Pro' started by zao8350, May 27, 2010.

  1. zao8350 macrumors regular

    Joined:
    Jul 2, 2009
    #1
    so i just bought a 23" samsung LCD for my june 09 mbp. the 2.8ghz 15". My plan was to run it in clamshell mode and a made a little stand that i put the laptop underneath and the monitor on top of. Problem, when I do this my wifi gets really weak. when i play games my ping is around 250 when it is normally in the 40's. i figured it was probably because the laptop was under stuff so i moved it out and to the left. same problem. i started leaving the laptop open but the problem persisted. i moved the laptop to the left of the display and still, the same problem. I then opened it on the left and problem solved. any idea why this is happening and if clamshell mode normally kills wifi reception? thanks!
     
  2. Poelser macrumors newbie

    Joined:
    Jun 12, 2010
    #2
    So, I'm posting in here since I also have problems with WIFI when I connect my MBP (2010) to an external display. As soon as I plug it in, the connection is lost.

    I read that this problem occurs sometimes and tried every solution I found including:
    - greater distance between external display and MB
    - lid closed/open
    - change wifi channel
    but nothing has worked so far.:confused:

    It actually cannot be due to disturbances caused by the display because WIFI works just fine when the display is connected to a windows machine while the MBP is directly next to it.

    Anyone got any advice?
    I considered:
    a) buying a wifi router supporting n-standard
    b) buying a mini displayport/dvi adapter from Apple (cause mine is not)
    but I hesitate to spend more money on it when it might be just for nothing.
    Thanks!
     

Share This Page