Wifi extremely slow on new iMac 2013

Discussion in 'iMac' started by NICKXXXXXX, Dec 3, 2014.

  1. NICKXXXXXX macrumors regular

    Joined:
    Oct 9, 2014
    #1
    Hey! So I just got my new iMac but I haven't been able to really enjoy it yet. The wifi on it is so slow for whatever reason. Both my MacBook and iPhone have no problems with the wifi. My iMac doesn't even load websites most of the time!
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    do a speed test from both your Macbook and your iMac and post up the output here.
     
  3. NICKXXXXXX thread starter macrumors regular

    Joined:
    Oct 9, 2014
    #3
    I'm at work now but will do that when I get home! If I can even get to the speed test site on my iMac haha
     
  4. fastlanephil macrumors 65816

    fastlanephil

    Joined:
    Nov 17, 2007
    #4
    I assume you have password protection for web access so no one around you is hitching a free ride.

    Try reinitializing your modem, router or what ever you're using. Turn everything off, wait 15 seconds and then back on.

    If there are other wireless routers around you make sure you are connecting to yours and not your neighbors.
     
  5. fastlanephil macrumors 65816

    fastlanephil

    Joined:
    Nov 17, 2007
    #5
    I'm assuming you have password protection for web access so no one around you is hitching a free ride.

    Try reinitializing your modem, router or what ever you're using. Turn everything off, wait 15 seconds and then back on.

    If there are other wireless routers around you make sure you are connecting to yours and not your neighbors.
     
  6. NICKXXXXXX thread starter macrumors regular

    Joined:
    Oct 9, 2014
    #6
    Yeah we have password. I'll try turning off after I've done the speed test
     
  7. NICKXXXXXX thread starter macrumors regular

    Joined:
    Oct 9, 2014
    #7

    2 mbps up and down on MacBook and 0.86 down and nothing on upload since Internet gave up. The Internet is 100/10 but I live on the bottom floor in a 3 story house. The router is on top floor. Internet is unstable down here. Sometimes I'll download torrents at like 5mbps and sometimes it won't work at all. I can always surf though. Might move to the room at the third floor. It's just that this room has some advantages. It's also only me whom is up right now
     
  8. steve23094 macrumors 68020

    steve23094

    Joined:
    Apr 23, 2013
    #8
    It sounds like you're expecting too much in terms of the quality of your wifi signal. Investigate the possibility of installing some Homeplugs.
     
  9. NICKXXXXXX thread starter macrumors regular

    Joined:
    Oct 9, 2014
    #9
    I talked with apple support now and it works! We deleted the system preference folder and my wifi works great now
     

Share This Page