WiFi Extremely unreliable under Vista Business - "Broadcom 802.11n"

Discussion in 'Windows, Linux & Others on the Mac' started by ChePibe, Jun 8, 2009.

  1. ChePibe macrumors member

    Joined:
    Jan 27, 2005
    #1
    Machine is a 15" MacBook Pro, Early 2008 (last of the non-glossy variety). Router is latest Dual Band Apple Airport Extreme.

    Device manager lists the driver version as 4.170.25.12 and Service description is BCM43XX. Driver comes from a fresh install of Boot Camp drivers.

    The wireless card works just fine - very well, actually - on the Mac side, but the moment I switch to Vista, I lose any ability to connect at N speeds and get a maximum connection of 36 mbps, and usually closer to 11 or 14.

    Do newer drivers exist? I've been googling for quite some time and I can't find anything that seems to work on the mac. Any ideas?
     
  2. limo79 macrumors regular

    Joined:
    Jan 9, 2009
    #2
    Use brain and update Broadcom drivers to the latest release. Use search ! Same problems and questions 1000 times even if the answer is one topic below.
     
  3. ChePibe thread starter macrumors member

    Joined:
    Jan 27, 2005
    #3
    Wow.

    That was just so very helpful.

    How's about you "use brain" and read my post which said I've been googling for a long time on this exact topic? Broadcom's site is horrendous, and I can't find the drivers I need there. Anyone have a link to newer drivers?
     
  4. ayeying macrumors 601

    ayeying

    Joined:
    Dec 5, 2007
    Location:
    Yay Area, CA
    #4
    limo79 didn't say use google, that user recommended using search on these forums.
     
  5. limo79 macrumors regular

    Joined:
    Jan 9, 2009
    #5
    Sorry, I put link to Broadcom drivers few times. It is easy to find it.
     

Share This Page