Wifi from TimeCapsule won't connect to internet on a PC

Discussion in 'Mac Accessories' started by Apple fanboy, Jan 11, 2013.

  1. Apple fanboy macrumors P6

    Apple fanboy

    Joined:
    Feb 21, 2012
    Location:
    Behind the Lens, UK
    #1
    So I have a late 2012 iMac running ML. I have no problems accessing the internet with it either through Wifi or ethernet cable. I also have no problems on my wifi connecting my 2 iPads or iPod touch or iPhone.
    However I do have a problem with my windows 7 laptop, windows 7 Netbook and my 2 Xboxes. I have read and tried the other suggestions I could find on here but no joy. Here are the details of my set up.
    Cable router (Virgin Super Hub) set to bridge mode. Connected to Time capsule by ethernet cable (running 7.6.1). Time capsule connected to iMac via ethernet cable. All work well. When I try to connect my PC's (or Xbox) it has no trouble finding the strong signal. I enter my password and I'm connected. On my PC's I attempt to connect to the internet (which it says I can in the Network settings) and it takes ages to load the page, like 2 minutes. Or more often than not it comes up with an error saying DNS Error. I have read and tried the suggestions by GGJ Studios in these threads;

    http://forums.macrumors.com/showthread.php?t=669201
    http://forums.macrumors.com/showthread.php?t=730718&page=3
    http://forums.macrumors.com/showthread.php?t=567270
    Any help much appreciated. I include some screen shots of my settings as well.
    Not sure if those boxes should be blank or not. I also include something else I tried from another thread which didn't help either.
     

    Attached Files:

  2. Apple fanboy thread starter macrumors P6

    Apple fanboy

    Joined:
    Feb 21, 2012
    Location:
    Behind the Lens, UK
    #2
    So incase someone is having an issue similar to this one here is what I did.
    Open Airport utility on your Mac.
    Select your time capsule and edit (it may need unlocking).
    Select wireless then wireless options.
    Check the 5GHz box and then manually select channels for both 2.4GHz & 5GHz channels. When doing this, be sure not to select channels in use in your neighbourhood. To check this click on about this Mac, More information, System report. Scroll down the left and select Wi-Fi and you will see what channels are in use. Choose one furthest away from those numbers. This worked for me. Hope it will for you to.
     

Share This Page