wifi good in Fusion, random disconnects in Leopard

Discussion in 'MacBook Pro' started by cloudserver, Jun 13, 2008.

  1. cloudserver macrumors newbie

    Joined:
    Jun 13, 2008
    #1
    I've seen multiple threads discussing random wifi disconnects, and I've tried most if not all the remedies without success. I've just noticed that if I'm running XP or Vista in Fusion and if my wifi connection in Leopard "stops working" (can't connect to any websites or ping computers on my network but the bars at the top are indicating an excellent connection) my network connection in the XP or Vista session in Fusion works just fine. I can still browse the web and connect to my network computers etc. If it was the Macbook Pro's hardware neither would work so it must be Leopard related. So come on Apple, please fix it!! I'm running 10.5.3. Has anyone else with the intermittent dropouts tried Fusion to see if Windows network connections still work?
     
  2. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #2
    why are you running wifi in fusion? that could be your problem right there.

    let OSX handle the network stuff, just enable networking to OSX through fusion...

    ???
     
  3. cloudserver thread starter macrumors newbie

    Joined:
    Jun 13, 2008
    #3
    I didn't say I was "running wifi in fusion"... I said that while in Fusion my network connection works fine, even while my Leopard wifi connection doesn't work. I am letting Leopard handle the wifi connection.




     
  4. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #4
    just reread it. still odd you lose connectivity in the HOst OS, and still have it in xp/vista.

    what does your ethernet/wifi tcp/ip say when this happens (inside 10.5) I wonder if the IP address is being dropped because of vmware.
     
  5. cloudserver thread starter macrumors newbie

    Joined:
    Jun 13, 2008
    #5
    Thanks for responding with some ideas. It occurs when I'm not running Fusion too, so I don't feel VMWare has any bearing on the issue. Yes I agree it's odd that the VM still has connectivity and the Mac OS doesn't. That was my point. Actually, the intent of my post was to perhaps add another piece of information to the many posts concerning MacBook Pro's suddenly losing their wifi connection. In my case , it's been happening since I purchased the computer ~6 months ago (and has gotten worse with the last 2 OS updates). I was hoping that maybe with some additional information a light bulb would go off for someone and lead to a remedy.

    When this occurs, my Mac OS shows a 169.254.x.x address (I forgot what the last 2 octets were), which I believe indicates the machine is only connected to itself (local link). When my Mac OS connectivity is working correctly my IP is a DHCP assigned 192.168.0.x address.



     
  6. jmervini macrumors newbie

    Joined:
    Jun 16, 2008
    #6
    Just want to add to this thread that I am also seeing this problem with wired connections.

    I use parallels for VM and like the previous posts, on the VM operating system (XP in general cases) I have no problem with the bridged ethernet device getting anywhere on the web.

    However on the Mac side of things, especially after a reboot I will get permission denied when I try to ping any devices on the subnet that I am connected to, even the local address (not localhost). My IP address is static so there is no issue with pulling an address from a server. I have tried resetting the interface both from the Networks sys pref and via command line with no success.

    After a period of time the connection will correct itself but it is baffling. I am in agreement that it seems leopard related because I did not have this problem with tiger.
     

Share This Page