WiFi hardware failure?

Discussion in 'iPhone' started by sibruk, Oct 20, 2008.

  1. sibruk macrumors 6502a

    Joined:
    Sep 17, 2007
    Location:
    UK+US
    #1
    I'm seeing something very weird on my iPhone 3G. It won't connect to WiFi, and I've just realised that something's up in my Settings screen.

    WiFi is greyed out completely and says "No WiFi". Anyone else seen this?
     

    Attached Files:

  2. scouser75 macrumors 6502a

    Joined:
    Oct 7, 2008
    #2
    Yup mate. I've got the same problem. It seems that its a hardware failure. If you take it back to the store they will exchange it for you.

    Unfortunately for me, I got mine from Italy and so am lumbered with a defective handset :(
     
  3. skubish macrumors 68030

    skubish

    Joined:
    Feb 2, 2005
    Location:
    Ann Arbor, Michigan
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F136 Safari/525.20)

    try a reset or restore first but yeah it sounds like you need to take it back to apple.
     
  4. scouser75 macrumors 6502a

    Joined:
    Oct 7, 2008
    #4
    I've tried everything under the sun to try and resolve this problem - reset, restore, jailbreak etc etc etc but nothing works.

    There is one thing I read today which Im gonna try later tonight:

    Fully charge the phone. I mean to the MAX. Then, whilst the phone is stil on charge do a soft rest/reboot. This method worked for one person, so fingers crossed (but not holding my breath :( )
     

Share This Page