WiFi in menu bar won't update

Discussion in 'OS X Mavericks (10.9)' started by darnocs, Nov 24, 2013.

  1. darnocs macrumors regular

    Joined:
    Jul 24, 2009
    #1
    I noticed a problem with Mavericks lately. I did a fresh install on my new hard drive and used Migration Assistant to import my stuff back. Everything was working fine: I click the WiFi button in the menu bar, the little scanning wheel spins, and it refreshes the list of wifi networks nearby.

    Then, I clicked "Open network preferences…" to view my network settings (didn't change anything) and now when I click the WiFi button in the menu bar, it doesn't refresh or scan for new networks. I know it's working because I can go to Network settings > Assist > Diagnose and it has a pop-up box that shows me refreshed networks, but the WiFi button doesn't work anymore. Can anyone see if they have the same bug, and does anyone know how to fix it? Restarting doesn't seem to do it.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Go into System preferences-> Network and there get off your wireless. Then while still in the Network pane look at the top of the pane for 'Location' Use the 'Location' drop-down to 'Edit'. In the 'Edit' pop-up click the + button and add a Custom named Location and then click 'Done'. Then to completely save this new Location by clicking the 'Apply' button to completely save this new Location. Lastly turn your wireless back on and see if this helps.
     
  3. darnocs thread starter macrumors regular

    Joined:
    Jul 24, 2009
    #3
    Unfortunately it didn't fix my issue, which is that the WiFi button won't initiate a a scan for and display new networks.
     
  4. Modernape macrumors regular

    Joined:
    Jun 21, 2010
    #4
    Yes - I've noticed this a few times too, though not every time. Turn wifi off/on again seems to fix it.
     
  5. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #5
    Another step requires some scary stuff and a reboot. This fix is in these steps:

    1. Turn off wireless.

    2. Go into /Applications/Utilities/Keychain Access.app and find any of your network passwords and delete them.

    3. Go to the folder (in the main folder)Y/ourHardDrive/Library/Preferences/SystemConfiguration/ and move the file: com.apple.airport.preferences.plist to your desktop Trash can but don't empty just yet).

    4. Immediately Reboot! This will rebuild that file.

    5. Upon the Reboot open system :preferences->Network pane and select Airport (if your Airport card doesn't show just use the + button to add it back). Then use the Network pane to rejoin your wireless network and you will have to save the password again.

    Try this and if it works than you can empty your Trash Can, if put that file back and reboot again. Good Luck
     
  6. darnocs thread starter macrumors regular

    Joined:
    Jul 24, 2009
    #6
    This only works until I put the computer to sleep. Then when I wake it up from sleep, the problem starts all over again.
     
  7. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #7
    This tells me that either you need to reboot your wireless router especially if it is more than two years old. Also once you get into your wireless router make sure you have remote administration turned off because this is way hackers are highjacking home routers.
     

Share This Page