Wifi, internet, dropping connection, university network - possible solution

Discussion in 'OS X Yosemite (10.10)' started by lun, Sep 11, 2014.

  1. lun macrumors newbie

    Joined:
    Sep 6, 2014
    #1
    Hi!

    I own a Macbook Air mid 2012 and since Mavericks my internet connection is driving me crazy.

    I am on a university network with a 100 MBit connection and use wifi in my apartment.

    When I use the standard settings set by my isp (university network) through DHCP, I can only download or browse alternatively, but not do both at the same time. As soon as a download starts, every other program loses internet connection. I can't even ping my router anymore and have to wait until the download finishes. :eek:

    After sleep or restart my mac needs minutes to regain connection, although wifi network itself is stable/seems connected and other devices connect just fine to the internet through the router.
    I have to manually reconnect, to make it work again. Highly annoying.

    Interestingly, other devices don't have this problem, notebooks with windows work perfectly in this environment. Mountain Lion in a VM works perfectly as well.

    Then I recently discovered Google Chrome Canary and a test showed, that as long as I used this browser for downloads, those problems were gone. :confused:

    Somewhere someone wrote, that Chrome uses a different DNS-Server. And that Yosemite seems to have problems with DNS-Servers...
    Read about ARP bugs as well but changing those settings did not work on Yosemite and did not have a great effect on Mavericks.

    I gave the DNS hint a try:
    When I select a different DNS-Server, (e.g. Google) it seems, my connection is working fine even after sleep or restart.
    I can download using whatever program I prefer and happily browse the internet at the same time.

    Problem: I cannot connect to the intranet (university network) anymore so I can’t login to the internet. :p

    Solution 1: I can login through a different device but apparently will not be able to connect to the intranet anymore using my mac. :(

    Solution 2: I have to add both DNS-Servers manually - Google and University

    Problem not solved entirely:
    As soon as I try to connect to the intranet while downloading, this still is not working. So it’s either intranet or internet but not both at the same time.

    So if you are on a large network and run into similar problems, try this and see if it works:
    Go to
    system preferences → network → wifi → advanced → DNS

    Write down the one which DNS-Server is already set.
    → add a different one (Google, OpenDNS, whatever) first AND the one you had before
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
    You can have multiple DNS servers listed. It uses the top as default but reverts to others when you have problems connecting.

    Check out name bench to find best servers for you.

    Test your network connection.

    First, time a site that loading slow for you. This site is suggested to test since it loads slow. Sports Illustrated: http://www.si.com You should instantly know if things have improved when visiting that site. (note: loads in under 1 second for me)

    Download and run: Namebench (free) http://code.google.com/p/namebench/

    Once you have the fastest domain name servers, you then have to manually change your DNS settings in System Preferences/Network/

    Select different browsers under the popup. I got varying results when using different browsers. Surprisingly, Firefox suggest Google Public DNS as primary, but Chrome and Safari gave me same settings.

    System Preferences > Network > Select you internet service (be it Airport, Ethernet etc) then click advanced tab > Select DNS and enter the settings

    Another option is to try turning off IPv6:

    In System Preferences --> Network -> choose the Ethernet tab in the far left column --> Advanced button -> TCP/IP tab --> Configure IPv6: dropdown menu, choose Off --> Okay button.

    The reason that turning IPv6 off may improve performance is that some DNS servers do not properly respond to IPv6 requests. As a result, your computer has to time out waiting for a response and then try a secondary DNS server.

    In recent versions of OS X, IPv6 typically is set to "automatic" by default. You have nothing to lose by turning IPv6 to "off" and then seeing if performance improves.

    Hope this helps!
     
  3. lun thread starter macrumors newbie

    Joined:
    Sep 6, 2014
    #3
    That is why I wrote, you need to add every DNS-Server manually, if you need both of them. Which I apparently do for the intranet to keep working.

    In preferences, when you add one, the standard one disappears/gets replaced.
    I didn't discover the replacement (thought, it was a glitch) until I got logged out and tried to log in again and then had to readd the DNS-Server manually.

    It's just a workaround. Better, than mono tasking.

    I tried to turn off ipv6, but I only get "automatically", "manually" or "link-local only" in the drop down menu. There is no other option to simply turn it off although my university doesn't support ipv6 at all.
     

Share This Page