wifi/internet issue iPhone 4s

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cosmicjoke, Feb 13, 2013.

  1. cosmicjoke, Feb 13, 2013
    Last edited: Feb 13, 2013

    cosmicjoke macrumors 6502

    Joined:
    Oct 3, 2011
    Location:
    Portland, OR
    #1
    hey all, i've been having an issue over the last few days with my iphone 4s dropping internet connection over wifi several times a day... the phone's wifi itself seems to be at least partially working when the internet drops out, as i'm still able to use it as a XBMC remote for my mac mini... the quick work around is to go into settings on the phone and toggle the slider for WiFi off and on again... i can use the internet again and all is well...

    this problem also seems to have manifested once today for my partner's iphone 4s.... i went as far as to do a restore on my iphone since i don't use it for much these days other than downcast and xbmc remote heh, but alas the symptom remains...

    what confounds things more though is we updated from ios 6.0.2 to 6.1.1 roughly around the same time as upgrading firmware on our AEBS Base Station to 7.6.3 along with the new Airport utility 6.2... none of our other wireless apparatus exhibits any symptoms though (two late '11 15"s, 1 rMBP, tivos) all are doing fine... i feel like a firmware update is responsible for this though, just not entirely sure which.

    any thoughts with how to troubleshoot this?

    thanks, cj
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Try a DFU restore on the iPhone. See if that fixes it.
     
  3. Daremo macrumors 68000

    Daremo

    Joined:
    Jul 3, 2007
    Location:
    Chicago
    #3
    I've been plagued with wifi issues in my 4S since 6.0. It's been a nightmare. I've tried DFU restore, and just about every "fix" people have offered. The Apple support forums have HUNDREDS of posts all with wifi issues. I took the phone into the Apple Store, and it magically works there, perfectly. Logging into ANY other wifi spot, full bars, and it freezes up or shows speeds less then dial up. I know of this issue on at least four 4'2 and 4S's since the update. Update after update, and the issues isn't fixed. Things worked perfectly before updating to 6, so I know this HAS to be software.
     
  4. cosmicjoke thread starter macrumors 6502

    Joined:
    Oct 3, 2011
    Location:
    Portland, OR
    #4

    Yah, I still have problems... I have latest gen AEBS and two iPhone 4s in household... I don't really use the wifi on my 4s elsewhere, pretty much all 3g so I can't really say if it's an issue with my AEBS or 4s or both or what... I do know that none of my Macbook Pros (there are 3 in house) or either of my Apple TVs have wifi issues, just these damned iPhones, so it seems to indicate more of a problem with them...

    I downloaded an app called iStumber and ran it to see if other people near by were also using the same channel as me, and ended up changing the 2.4ghz channel on my AEBS to 8 (nobody but me seems to have a 5ghz channel near by so I left that on auto) but that didn't really help... The thing is this problem can happen a few times in a night or not happen for 2 weeks... The phone always shows the wifi as having a full connection, it's just the internet connectivity that drops out.. I have to toggle the Wi-Fi slider in Settings on the phone to access anything internet related again. Look forward to my contract being up to get a new phone fairly soonish.
     
  5. inoob89 macrumors newbie

    Joined:
    Apr 21, 2013
    #5
    iphone 4s new

    I just got what i assume is a brand new iphone 4s from my verizon store, the wifi has yet to work. I've had apple tech before and used those devices on the same wifi networks with no problems and my laptop and ps3 are working with full signal. the iphone shows full bars and says i am connected to my network it will even bring up to google home page and i got facebook home page to come up once after i tried the whole plane mode on reset deal, but as i tried to log in it stopped working again. I've read alot of forums with complaints about wifi connection with iphones and some say to upgrade but mine is running the latest ios so it must be a hardware or manufacturing issue right? also my friends ipad although it works, runs exceedingly slow on wifi. Of course they both work great when running on 3g but i cant afford and shouldn't have to pay for that when i'm around a wifi source 90% of the time. So i'm thinking of jumping ship on the iphone maybe for the new galaxy unless anyone has better suggestions or knows a solid way to fix. I love the iphone and ios but without wifi it's just a touch screen phone with a good camera.
     
  6. cosmicjoke thread starter macrumors 6502

    Joined:
    Oct 3, 2011
    Location:
    Portland, OR
    #6
    Airport 7.6.4 firmware update:

    - Resolve an issue that may intermittently cause a loss in Wi-Fi connectivity with iOS devices

    Well, would you look at that.
     

Share This Page