Wifi issue on Yosemite despite using A.Extreme

Discussion in 'OS X Yosemite (10.10)' started by DJTaurus, Jun 17, 2015.

  1. DJTaurus, Jun 17, 2015
    Last edited: Jun 17, 2015

    DJTaurus macrumors 65816


    Jan 31, 2012
    1) I am using the latest Airport Extreme with a MBair Haswell (supports 5GHz) and i get daily the following issue.....many times after sleep mode the wifi speed is slow as hell... the trick to close open the wifi doesnt change anything... changing also connection from 5Ghz to 2.4Ghz doesnt do the trick. Only solution to get back full speed on my Wifi is to reboot the Macbook or to change wifi channels on wireless option of Airport Utility. BT is always turned off.

    2) Another issue is that sometimes the search bar on safari stops working...? Freezes and stops.

    It happens only on Mac.... no issues with iphone 6's wifi all these months... maybe the signal drops sometimes but no speed issues there.

    Whats going on?... how many updates do they need to fix those issues? Apple tells us that we should wait more months until El Capitan... i am totally disappointed on them.

    ps1 - also airdrop functionality is another joke.... takes ages to find my iphone and most of the times needs mac reboot to get it working.

    ps2 - dont suggest me to do a clean install. I have done it twice since yosemite.
  2. Ardmanz macrumors regular

    Jul 12, 2013
    The wifi issues you describe are quite common in Yosemite, I also suffer the same problems.

    There are not any reliable fixes, just some temporary work arounds.

    10.10.4 supposedly fixes the issue which should be released shortly.
  3. DJTaurus thread starter macrumors 65816


    Jan 31, 2012
    Apple should really fix the wifi issues. It is becoming ridiculous every time to check my router if it has the problem (changing channels and rebooting) or calling my ISP provider to check my line and if it has any problem with noise etc.... and when i JUST REBOOT MY MAC wifi full speed comes back instantly. Wifi on/off doesnt do the trick. Seriously its a shame....its a shame BECAUSE back in the first days of Yosemite when the problem first occured and people didnt know what was going on with slow wifi speeds i bought an Airport Extreme only for this... because i thought it was my old routers problem... and then more and more people were reporting wifi issues after upgrating to yosemite. Now i am back to my old router but i have to reboot my Mac once or twice a week.... :mad::mad::mad::mad::mad::mad::mad:
  4. Ardmanz macrumors regular

    Jul 12, 2013
    Yes, it's very frustrating. Mine gets worse by the day. I hope the next update fixes it. If it doesn't I think I'll go back the Mavericks.
  5. DJTaurus thread starter macrumors 65816


    Jan 31, 2012
    Mine even happens after sleep mode..... more more frequenlty.
  6. DJTaurus thread starter macrumors 65816


    Jan 31, 2012
    It seems latest Yosemite update has fixed Wifi issues: Mail App on Mac notifies immediatly when new mail arrives like my iPhone and it seems that Mac connects to Wifi instantly when i open it from sleep mode.... for example tweetbot refreshes instant when it needed some seconds in the previous versions. I HOPE THEY will remove discoverability file from iOS too.
  7. crjackson2134 macrumors 68020


    Mar 6, 2013
    Charlotte, NC
    Please show me where "Apple" has ever told anybody they should wait months until El Capitan is released to fix an issue.

    Are you sure that you weren't overreacting due to your disappointment and simply felt like this must be the case?
  8. Che Castro macrumors 603

    May 21, 2009
    I had bad wifi issues on Yosemite and AirPort Extreme
    What fixed my problem was restoring the AirPort Extreme to factory settings and starting over

Share This Page