wifi issue

bellboy1982

macrumors member
Original poster
Aug 6, 2012
34
0
Scotland
Hello,

My 2012 MBA 8gb 128SSD has issues connecting to my wifi after sleep mode or a full shutdown.

The wifi indicator just flashes as if looking for wifi even though mine is listed. I have to switch the wifi on and off on the MBA before it will connect.

This isn't everytime but at least 7/10 times i have to do it.

Any ideas whats up?
 

satcomer

macrumors 603
Feb 19, 2008
6,430
980
The Finger Lakes Region
Try one of these steps to fix your Wi-Fi:

1. Open System Preferences->Network, Advanced button. Then in the Preferred Networks section delete any other wireless networks that are not your wireless network.

2. First turn of the wireless in your Mac. Then open again System Preferences->Network and then at the top of the Network pane choose the 'Location' drop-down and select 'Edit Locations...'. When the mini popup comes up click the + button to add a new costumed named Location (Don't worry it will act the same as 'Automatic'). Then click all the saves and when you go back to the Main Network pane make sure you click on the 'apply' button to totally save this new Location. Lastly rejoin your wireless network.

3. If you have an older cheap router that is at least 2-3 years old open again System Preferences->Network, Advanced button, Hardware mini-button and change the MTU size down to a smaller size.


4. Reboot your wireless router and if that doesn't work in the wireless router change to a new wireless channel.

5. Reset Your PRAM .

Good Luck.
 

bellboy1982

macrumors member
Original poster
Aug 6, 2012
34
0
Scotland
Try one of these steps to fix your Wi-Fi:

1. Open System Preferences->Network, Advanced button. Then in the Preferred Networks section delete any other wireless networks that are not your wireless network.

2. First turn of the wireless in your Mac. Then open again System Preferences->Network and then at the top of the Network pane choose the 'Location' drop-down and select 'Edit Locations...'. When the mini popup comes up click the + button to add a new costumed named Location (Don't worry it will act the same as 'Automatic'). Then click all the saves and when you go back to the Main Network pane make sure you click on the 'apply' button to totally save this new Location. Lastly rejoin your wireless network.

3. If you have an older cheap router that is at least 2-3 years old open again System Preferences->Network, Advanced button, Hardware mini-button and change the MTU size down to a smaller size.


4. Reboot your wireless router and if that doesn't work in the wireless router change to a new wireless channel.

5. Reset Your PRAM .

Good Luck.

Thank you, i'll try that now.
 

DonNaegele

macrumors newbie
Mar 9, 2012
8
0
After having issues for weeks losing my connection sometimes several times an hour I CAN CONFIRM that after upgrading to 10.8.1 I've not had the issue even once in almost 24 hours.

Don