iPhone 8(+) Wifi Issues and lag?

Discussion in 'iPhone' started by SquireSCA, Apr 13, 2018.

  1. SquireSCA Suspended

    SquireSCA

    Joined:
    Dec 5, 2008
    Location:
    Atlanta, GA
    #1
    Running the latest iOS 11.3 official release... 256GB iPhone 8+. I have no other issues with the phone, apart from lag and wifi issues.

    I thought it was my AT&T supplied router, so I went and got a much nicer one and the problem persists.

    Netflix, Hulu, Facebook and Safari, all have really bad intermittent lag. Like it is just sitting there, stalls, and times out. Makes it really hard to stream to my Chromecast, but even things like FB, I launch it, it starts to load the page, and then just stops and sits there for over a minute, before continuing. Also does it via the browser when trying to look something up on Google or whatever.

    Doesn't seem to do it when I turn off Wifi and use LTE. But then I can't stream Hulu or Netflix to my home theaters so that's no help...

    Did it with the old router. So got a much better one. Tried both 2.4 and 5Ghz channels, same result. I also get it on my iPad Pro(also on 11.3) but not as often, but my wife is also on an 8+ with 11.3 and has none of these issues.

    I try to run SpeedTest(via the app) and it either can't do it because it says that I don't have an internet connection(despite showing full strength), or it does work and I get decent performance. It's not a signal strength thing as this can happen when I am 10 feet from the router with a clear line of sight. One minute I am getting great throughput, then a few minutes later it is telling me I have no internet connection.

    I have told it to "forget" the wifi connections and set them up again... I have also "reset all network connections" and that hasn't fixed it either. I really don't relish the idea of hard resetting my phone, as I did that a month ago and it's a pain in the ass to set it all up again...

    I have to say, I went back to an iPhone after many years in Android land and I am a bit disappointed... I see a lot of bugs and issues listed online and it seems that Quality Control from a software perspective, has really gone downhill.

    I see that 11.3 seems to have quite a list of bugs... Does anyone else have this particular one and is there a remedy?
     
  2. Chazzle macrumors 68000

    Chazzle

    Joined:
    Jul 17, 2015
    #2
    Are you using any ad/content blockers on your phone, or a vpn?
     
  3. SquireSCA thread starter Suspended

    SquireSCA

    Joined:
    Dec 5, 2008
    Location:
    Atlanta, GA
    #3
    Nope. Phone is bone stock, no VPN or ad blockers.

    Phone was fine since I bought it, but FB has always been laggy on it. Now everything else is laggy and it's really annoying. Tried all the settings, tried all the how-to's I found online, which really are no help. They just tell you to reset the router and phone and hope for the best, essentially.
     

Share This Page