WiFi Issues - I've searched high and low :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sullied, Aug 13, 2013.

  1. sullied macrumors newbie

    Joined:
    Aug 13, 2013
    #1
    Ok, so about a month ago, I noticed wifi issues at my house. I have an Asus RT-N12 that I've had for about 2 years now and have never had an issue. I have a desktop connected to it with ethernet. Then, I have an iPad 2, an iPad mini, iPhone 4S, iPhone 5, a Samsung laptop and my Blu-ray player all connected via WiFi. I noticed over my WiFi that my download speeds were ~1Mbps...sometimes less on my devices. Sometimes it was just the iPhones, sometimes it was all devices. I started troubleshooting and found part of the problem. I upgraded my computer recently...something in that upgrade caused interference with the router when the computer was on and would slow everything on the network down. When it was off, everything was fine (except the iPhones). I've moved the router away from the computer and now all of my wireless devices get good speed, except the iPhone 4S and iPhone 5. My computer that is hardwired to the router will get download speeds ~22Mbps consistently. My iPads typically get ~18-20Mbps. The Blu-ray player seems fine over Netflix. However, my iPhones get ~1Mbps...still. Admittedly, they phones could've always been slow and I've never noticed because we typically use the computers or iPads when we are at home. Now that I know though...it's frustrating beyond belief. I've noticed that my iPhone pings are typically ~30ms to the router. Laptop is usually ~4ms, iPads are usually ~7-8ms. Here's what I've tried so far (these are in order):

    1. Moved router away from the computer (probable interference from CPU...fixed everything but the iPhones).
    2. Changed the WiFi channel to several channels and used inSSIDer to identify the best channel. This did not help at all.
    3. Updated the router firmware to the latest. No change.
    4. Changed the beacon interval setting on my router from 100 to 50. No change.
    5. Ensured that WPS is turned off on my router. It is.
    6. Ensured that WPA2+AES is being used for the security. It is.
    7. Changed the router mode of operation to 802.11n ONLY. No change.
    8. Reset the network settings on the iPhone to factory. No change.

    There's probably more that I've tried...but I'll welcome any suggestions. Also, my iPhones are running different versions of iOS. The iPhone 4S is on iOS 7 Beta 5 (I know it's a beta). The iPhone 5 is on iOS 6.0 (My wife REFUSES to update her iOS for some reason...don't ask me why).
     
  2. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #2
    If u can transfer stuff within your LAN normally, then maybe your ISP is at fault.
     
  3. dextr3k macrumors 6502

    Joined:
    Nov 26, 2012
    #3
    I don't know if you have tried this, but reset network settings for both the iphones and then turn OFF all security on the router. not even WEP. I believe 6.1 fixed some wifi issues, but that still does not explain your ios7's slowness.

    If you are still experiencing these speed issues, I would start thinking towards a new router. But I don't have any better ideas for you other than that.
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Looks to me as though you have covered all the bases...I'd be inclined to borrow a new router if you can just to check that it is at fault here. If the substituted device shows improved performance, then grab a new one.
     
  5. nancyfromafrica macrumors member

    Joined:
    Sep 17, 2012
    Location:
    Johannesburg
    #5
    yes it could be the fault of the ISP provider may be you should try LAN first
     
  6. sullied thread starter macrumors newbie

    Joined:
    Aug 13, 2013
    #6
    It's not the ISP. I get full download speed on my desktop consistently. I've also tried pinging my router from each device. The desktop (connected by wire) is <1ms every time. The wireless laptop and iPads are all low...few ms. The iPhones are consistently over 25ms.

    I'll give the router swap and turning off security a try. I've got a friend with an Airport that he's not using right now. I could borrow that for a couple of days.
     
  7. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
  8. sullied thread starter macrumors newbie

    Joined:
    Aug 13, 2013
    #8
    Well, I tried the turning off security thing...no improvement. I'm borrowing a friend's Airport router this evening...I'll give that a try to see if it's router related.

    Any other suggestions out there?
     
  9. sullied thread starter macrumors newbie

    Joined:
    Aug 13, 2013
    #9
    Well, I tried the Airport Express and it worked great with the iPhones. I guess my current router hates iPhones...weird.
     

Share This Page