Wifi issues with Mavericks OS

Discussion in 'OS X Mavericks (10.9)' started by CarlsbadMacUser, Oct 30, 2013.

  1. CarlsbadMacUser macrumors newbie

    Joined:
    Oct 30, 2013
    #1
    I just updated to Mavericks and now I can't connect to wifi. When I click on my own wifi network (from my router in the next room) I'm told my network "could not be joined. Try moving closer to your wireless router." (I am sure I'm not too far from my router, since I'm using wifi for my phone right now, while sitting in front of the computer.)

    I've also tried joining it as a new network in advanced settings, but then when prompted to enter my WPA password it just says "connection timeout"

    Any suggestions?
     
  2. CarlsbadMacUser thread starter macrumors newbie

    Joined:
    Oct 30, 2013
    #2
    Also, I tried using Network Setup Assistant (through Network Preferences) when I chose my network I was told my password was incorrect. But it was definitely not incorrect.
     
  3. missbritish macrumors newbie

    Joined:
    Oct 30, 2013
    #3
    I had issues with connection timeout. What you need to do is you need to login to your router's ip address and change your wifi channel and it should now connect to your wifi network. My router was on channel 11 so I changed it to 6 and I was able to connect. Channels 1,6,11 are supposed to be the best channels in getting the best wifi signal.
     

Share This Page