WiFi issues with new MBP on 2.4GHz

needlz

macrumors member
Original poster
May 14, 2008
71
2
Zurich, Switzerland
I've a new MBP, which connected fine to all WiFis until a few weeks ago. Does anyone know what I can try to resolve the issue?

The error says "The Wi-Fi network ... could not be joined.

This is what I've done so far:

- Tested multiple WiFis on 2.4Ghz (5Ghz works fine)
- Checked if passwords are correct (works by joining with an iPhone)
- Reset PRAM and SMC
- Just for the sake of it, changed MAC address (but there is no MAC filtering enabled..)
- Created a new location and used the assistant to connect (here the error said "password is incorrect").

I'm running macOS Sierra 10.12.6. Appreciate any help.
 
Last edited:

chown33

Moderator
Staff member
Aug 9, 2009
8,725
5,040
vertical
Start with Wireless Diagnostics. The actions needed to run it are under the "Analyze your wireless environment" heading:
https://support.apple.com/en-us/HT202663

The Utilities window is used for the following, not the Diagnostics window. See the heading "Use other diagnostics utilities".

1. Do a Scan (search for it on the web page), and post the RSSI for the networks visible. Signal strength, interference, other networks, etc. can have a large effect.

2. As suggested above, make sure Caps Lock isn't enabled. Then delete the saved network and enter the info again.

3. Run the Performance graph when connected (search for it on the web page). Quality and Signal give info on signal quality, which is affected by signal strength, interference, distance, etc.
 

kohlson

macrumors 68020
Apr 23, 2010
2,265
661
The error message suggests that it's a signal strength issue. Following the above will provide good insight.
- Can you connect to other 2.4 GHz networks?
- Are all the signal bars in menu bar at the top showing?
- Are you far away from the router, with metal/stone objects in the way?
 

imaccooper

macrumors 6502
May 29, 2014
305
97
North Carolina
A few things to try...

1. Go into wireless settings and delete the network from saved and then try to reconnect. If encountered so many weird things with old saved networks.

2. Move your router around to see if there is interference nearby (Bluetooth, sound systems, microwaves, pretty much anything). Since 5ghz works fine, physical objects are likely not the problem because they would affect 5 more than 2.4, but things mentioned above will affect 2.4 more than 5 especially microwaves.

3. Delete network as mentioned above then before reconnecting, put your Mac right beside the unit within a foot or so and try to reconnect. If this works then your antenna is likely the problem.

4. Unlikely to be the problem, but make sure you are getting a proper IP address and subnet for your network. I've had this happen before and ended up having to set a manual ip address with dhcp. Very annoying.
 

Fishrrman

macrumors Core
Feb 20, 2009
19,095
6,541
Just wondering -- do you have anything plugged into the USB-c ports while you're trying to establish the connection?

Why I asked:
Could be interference from USB3/USB-c ...
 

needlz

macrumors member
Original poster
May 14, 2008
71
2
Zurich, Switzerland
Thanks for all the replies! I've doubled-checked the passwords (e.g. no CAPS LOCK), no USB* devices are plugged in, deleted all network settings (and also logged in with the "guest" account). I'm slowly beginning to think that it's a hardware issue and will check with a local Apple Store.
 

woodini

macrumors newbie
Sep 14, 2017
2
0
London
I'm having the same issues yesterday on a 3 week old 12" Macbook. Previously I had removed all of the SSIDs from the Wireless preferences from stations I no longer connect to. Thankfully I didn't remove my home ones or my iPhone tether. It won't connect to anything else now. I've done a permissions fix, checked the keychain, tried connecting from the guest account etc. Very frustrating.

Edit: I popped into an Apple Store this morning and chatted with a member of staff who advised I remove the WiFi adaptor entirely from my Network location, then re-add it. That seems to have worked.
 
Last edited:

needlz

macrumors member
Original poster
May 14, 2008
71
2
Zurich, Switzerland
Edit: I popped into an Apple Store this morning and chatted with a member of staff who advised I remove the WiFi adaptor entirely from my Network location, then re-add it. That seems to have worked.
Unfortunately that didn't to the trick for me. I might give updating to High Sierra a try this week, before bringing it to the Apple Store.
 

woodini

macrumors newbie
Sep 14, 2017
2
0
London
I ran into a similar problem with a client of mine last Friday and was able to get around it by manually adding the SSID and security details back in by using the '+' option in Network Preferences > WiFi > Advanced > Preferred Networks.

Might be worth a go?
 

needlz

macrumors member
Original poster
May 14, 2008
71
2
Zurich, Switzerland
I ran into a similar problem with a client of mine last Friday and was able to get around it by manually adding the SSID and security details back in by using the '+' option in Network Preferences > WiFi > Advanced > Preferred Networks.

Might be worth a go?
Thanks - I just tried a final test with booting via Recovery Disk (so no installed configurations/drivers are loaded) and trying to connect from there - still showing the same error. I guess I'll have to find time for an Apple Store visit now..
 

nzwinmac

macrumors newbie
Mar 19, 2019
1
0
Thanks - I just tried a final test with booting via Recovery Disk (so no installed configurations/drivers are loaded) and trying to connect from there - still showing the same error. I guess I'll have to find time for an Apple Store visit now..
I just spent half a day debugging issues with WiFi on my new MacBook Pro. Same problem as described in this thread. Issues only on 2.4GHz. Well, apparently USB3.0 is to blame, as it creates interference on 2.4GHz. Disconnect all your USB devices from your Mac to confirm that this is the same issue you're facing.

OK fine, I understand, but why does my Android phone have no issues when sitting right next to the Mac? That makes me think that this issue is due to something that was badly designed by Apple. Very disappointing indeed!

see more:
https://www.intel.com/content/www/u...al-bus/usb3-frequency-interference-paper.html
https://discussions.apple.com/thread/8440574
https://apple.stackexchange.com/que...ing-wifi-on-2016-2017-macbooks-who-s-to-blame
 

irvinb2019

macrumors newbie
Oct 1, 2019
1
0
I found a solution: instead of connecting by choosing SSID.just click join other network and manually type the SSID and password- thats with an old 2.4ghz router where my parents live.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.