Wifi keeps disconnecting

Discussion in 'OS X Yosemite (10.10)' started by shaunbowers, Aug 1, 2014.

  1. shaunbowers, Aug 1, 2014
    Last edited: Aug 2, 2014

    shaunbowers macrumors newbie

    Joined:
    Oct 6, 2013
    Location:
    Whangarei
    #1
    I posted about this a few times in the Bugs Thread but got no response, ever since I upgraded to Yosemite the wifi will connect but disconnects like every minute.

    I've reset Network Settings, Re-setup the Wifi connection and all. My parents laptops are working fine (and mine that I'm typing off).

    Just curious how I could fix it, I've cleared all my cache today since Icons weren't working and the internet has been like this since the day I installed Yosemite.


    Thank you
     
  2. shaunbowers thread starter macrumors newbie

    Joined:
    Oct 6, 2013
    Location:
    Whangarei
    #2
    This is still not solved, I saw another thread to repair 'Disk Permissions' which I done and it worked great.

    Now it keeps coming back and cutting off, every time I do 'Repair Disk Permissions' it goes fine for about 20 minutes at the latest.

    Anyone got suggestion?
     
  3. iFapperPro macrumors newbie

    Joined:
    Aug 2, 2014
    #3
    The same problem

    I have experienced the same problem on MacBook Air(MD 760). At first, connection was OK, but in 20 minutes it failed.
    I didn't find the solution and restored to the Mavericks.
    This problem was on the public beta.
     
  4. ellinj macrumors newbie

    Joined:
    Aug 2, 2014
    #4
    I wonder if its got to do with the wifi router model, I upgraded to Yosemite while out of town and have been away all week. I just got home and having a horrible time with disconnects since I got home. I switched to tethering onto my iPhone and the problem went away.


    Maybe an excuse to go out and buy an airport. What are you all using?
     
  5. iFapperPro macrumors newbie

    Joined:
    Aug 2, 2014
    #5
    I use Tp-link, don't know the model because I am renting place. Some TPlink.
     
  6. GeePers macrumors newbie

    Joined:
    Jul 25, 2014
    #6
    I've had a problem that only happens on my 2011 iMac running Yosemite where the WiFi still shows connected, but there's no traffic between it and my AirPort Extreme. When I turn off WiFi and turn it back on then everything is back to normal. It's maybe happened twice since I install 10.10. So far the problem hasn't happened on my 2013 MacBook Air with Yosemite.
     
  7. iFapperPro macrumors newbie

    Joined:
    Aug 2, 2014
    #7
    We had better wait the stable version.
    It's good that I could connect in recovery to my hotspot and restore to 10.9
     
  8. HikariYuki macrumors regular

    Joined:
    Jun 29, 2009
    #8
    Had the same issue and reverted back to mavericks as well. Its hard to use the OS when the wifi isn't operating correctly.
     
  9. amoda macrumors 6502a

    Joined:
    Aug 9, 2006
    #9
    Same here, Mid 2012 rMBP. It's on pretty much all networks, my home, my uni's and in public areas like Starbucks.

    It keeps connecting and dropping, and then about 20-30 mins later it'll connect and stay connected...until it's put to sleep for longer than a few mins.
     
  10. crazyxzer0 macrumors 6502

    Joined:
    Oct 28, 2008
    #10
    Has anyone read the console logs to see what happens right when it disconnects?

    I haven't had an issue with any of my wifi networks , home/parents/office
     
  11. tuukka87 macrumors regular

    tuukka87

    Joined:
    Apr 5, 2012
    Location:
    The Colony,TX
    #11
    Having the same problem with my mid 2012 13" MBA
     
  12. Carlosgomes macrumors member

    Joined:
    Jul 3, 2013
    #12
    Same here. It doesn't happen too often, but only when the laptop is inactive for a while.
     
  13. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #13
    I just installed Yosemite release version, now I am having the same issue. Wifi keeps disconnecting every so often. Turning wifi off and back on fixes it, but only briefly.

    Yosemite release
    2011 24" iMac
    Apple Time Capsule in 802.11 b/g/n mixed mode.

    My 2011 MacBook Air is rock solid running Yosemite release on the same network, no wifi problems at all.
     
  14. JoshJosh117 macrumors 6502

    Joined:
    Nov 8, 2007
    #14
    Try this maybe:

    Go to Network in System Prefs
    Click advanced
    TCP/IP tab
    Click Renew DHCP Lease
     
  15. Parasprite macrumors 68000

    Parasprite

    Joined:
    Mar 5, 2013
    #15
    Here's what I've noticed:

    1. Randomly disconnects.
    2. Wifi network not selected.
    3. Clicking wifi network brings back internet. OR
    4. Clicking wifi network does nothing, no matter how many times I try...so I just turn wifi off/on and it works again.

    I had something vaguely similar on iOS for a while, but that has been fixed since iOS 8.
     
  16. shaunbowers thread starter macrumors newbie

    Joined:
    Oct 6, 2013
    Location:
    Whangarei
    #16
    I used to have the issue with the Beta Versions, but it fixed after I done Repair Disk Permissions in Disk Utility then Verify them. :)
     
  17. kronosqq macrumors newbie

    Joined:
    Jul 31, 2012
    #17
    Any of you on WPA2 Enterprise networks? Seems like hardly anyone here is based on the thread I set up for it, but connectivity stability with WPA2 Enterprise has been an issue since the first beta.
     
  18. Brocksley macrumors member

    Brocksley

    Joined:
    Nov 5, 2013
    Location:
    Utah
    #18
    Works fine from home, but at school where they use a WPA2 Enterprise it disconnects very frequently.
     

Share This Page