wifi not staying connected

Discussion in 'iPhone' started by mtfield, Mar 18, 2008.

  1. mtfield macrumors 6502

    Joined:
    Jan 9, 2008
    #1
    I was wondering if anyone had any ideas for my problem... my iphone has recently gotten into a weird thing where it can't stay connected to my wifi network. As soon as i wake the phone it connects to wifi, but as soon as i do anything that requires it to work over the wifi connection it doesn't work then drops back to edge. i can occasionally get it to work for a few minutes but always ends up dropping the signal and reverting to edge. distance is not the issue... i've done everything i can think of... i've told it to forget the network, reset the router, then connected again... ive reset my network settings, ive even restored the damn thing... anyone have any ideas??? has this happened to anyone else? it is quite frustrating... thanks for any help!
     
  2. todd11231 macrumors newbie

    Joined:
    Feb 28, 2008
    #2
    im going through the same thing right now. I was looking for an answer but havent found anything. Its like its dropping wifi to pick up edge when it should be the other way around. And this is only at work, my home wifi works fine. Plus it worked fine about a week ago. Let me know if you figure it out, and I'll keep this post updated as well.
     
  3. josielinnea macrumors regular

    josielinnea

    Joined:
    Dec 15, 2007
    Location:
    Stockholm
    #3
    I recognize this aswell.. do you guys also have 1.1.4? It wasn't like this before I updated. I have tried everything except going back to older versions - I've reset it, restored and the whole thing... -_-
     
  4. mtfield thread starter macrumors 6502

    Joined:
    Jan 9, 2008
    #4
    I went to apple today and told the genius about the issue... He swapped it out.. 5 min later I walked out with a new phone.. And now it works perfectly! Give it a try guys
     
  5. HeyKenny macrumors newbie

    Joined:
    Jan 6, 2007
    #5
    I've been having a similar problem. So far rebooting the phone has worked to reconnect to wifi. I had been thinking it was because my phone (Day1 1.1.4) was jailbroken (ZiPhone). Those of you who have been having similar probs - is your phone stock or have you jailbroken it?
     
  6. myphone macrumors 6502

    myphone

    Joined:
    Jan 15, 2008
    Location:
    USA
    #6
    That happpened to me too. It's not my iPhone, it's my home broadband connection. I reset it and my iPhone works.
     
  7. blueshirts macrumors newbie

    Joined:
    Jul 12, 2008
    #7
    :D I had a very similar issue and I found that it was being caused by a cheap netgear wifi card in one of my computers. After removing that device from the network the iPhone wifi seemed to work great. All my other computers worked fine though for some reason the iPhone had a problem with it. Maybe this will help someone.
     
  8. waldmeister macrumors newbie

    Joined:
    Jul 26, 2008
    #8
    I have a similar problem with a jailbroken 2G phone. I had it with firmware 1.1.3 and now with 2.0. The wifi connection is unreliable, connecting and dropping off with no apparent reason, even when I'm sitting right next to the router. Sometimes it remains connected for 20 minutes, sometimes for 20 seconds. When I try to reconnect I often get the message, "Unable to join the network XXX". This happens both with airport express and another router in another part of the house, as well as with hotspots out in the real world. Incredibly frustrating! This seems to be a widespread problem. Can anyone offer possible solutions? Thnx!
     

Share This Page