WiFi not sticking

Discussion in 'iPhone Tips, Help and Troubleshooting' started by wolfphantom, Jun 30, 2007.

  1. wolfphantom macrumors newbie

    Joined:
    Jun 30, 2007
    #1
    I have 2 iPhones that are having issues keeping a connection with a WiFi network with a WEP key. One phone seems to be staying connected more often, but the other phone just rotates between showing a connection to a WiFi network and then not. This happens every 30 seconds or so.

    During times it appears that it is connected to the network the "E" is still present in the upper-left corner of the phone.

    I have already deleted the network profile, turned-off WiFi, reset router, and reset the network into the phone. This did not solve or help the problem. Has anyone else run into this problem/issue with their iPhone. Any help would be appreciated.
     
  2. iomar macrumors 6502

    Joined:
    Dec 28, 2001
    Location:
    Los Angeles, CA
    #2
    Sorry that I can't help you, but I have the exact same problem with my iPhone. I have done everything you have tried here. I have even called the iPhone support line yesterday and was with them on the phone for 3 hours until they hung up on me. Today I setup an appointment to take my phone to the Apple Store for them to look at it. My iPhone sees my wireless wi-fi connection the bars at the top shows that it is in the wi-fi connection and stays there until I open the safari web browser of my iphone than it switches to the edge E. I have not yet been able to play any of the youtube videos and I have not been able to see a fast internet connection on my iphone.
     
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    Is this a WEP network you control, or one that someone else controls? What kind of key do you use (e.g. 64 or 128 bit)?
     
  4. iomar macrumors 6502

    Joined:
    Dec 28, 2001
    Location:
    Los Angeles, CA
    #4
    Where can I find this information? In my router? If so how? I am reading some other threads that people talk about WEP. But where can I check that. I have a 2WIRE modem and router. I have an iMac that is connected with Ethernet Cabel and this Macbook Pro which is connected wirelessly. I am not sure why my iphone can't connect or when it does it switches back to "E".
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    I'm not sure about your specific router...typically, you type the router's LAN address into a web browser (usually, it will either be http://192.168.1.1 or http://10.0.1.1 -- in fact, you can try clicking those links) and then browse over to the wireless security settings. I'm not 100% sure about why this would be an issue, but in the past, there have been lots of cases where the shorter keys -- the 64 bit ones, which are sometimes also called 40 bit keys -- are less reliable than the 128 bit keys.

    The iPhone *does* seem to be fairly picky about WEP for some reason, so you might also peruse other iPhone WEP threads to see if anything rings a bell with your setup.

    If the 2Wire supports WPA, you should really switch to WPA, which is better in every conceivable way, although that's certainly not an answer to your question.
     
  6. kyRx macrumors newbie

    Joined:
    Jun 30, 2007
    #6
    I'm having the same problem

    My phone just doesn't connect to my wireless network. My router is a D-link 802.11g/2.4 GHz one. I'm gonna try with my Airport base station and see what happens. Stay tuned.
     
  7. kyRx macrumors newbie

    Joined:
    Jun 30, 2007
    #7
    Problem solved!

    eddi818 on the other WiFi thread solved my problem:

    http://forums.macrumors.com/showthread.php?t=322475&page=2

    The problem, he (or she) found out, was the shift key. After selecting the network and before typing in the hex password, select the shift key, type in the password, and boom, problem solved (at least for him and me). Good luck.
     
  8. iomar macrumors 6502

    Joined:
    Dec 28, 2001
    Location:
    Los Angeles, CA
    #8

    Thank you very much! I just went to my routers sitting and changed it from WEP-Open to WPA and right away I was getting full single on my iPhone. I went to YouTube it worked great (i was finally able to watch videos) and I openned the safari and that too worked great and very fast (like the speed of my Macbook pro). After I made the change I did have problem with my MacBookPro not finding my router that was the reason it took me this long to come back and thank you. Anyway, I went to my iMac which is connected with an Ethernet cable and was able to log back to my router and changed some of the sittings. But actually, all I needed to do on my MacbookPro was to select my wireless connection from the airport choices on the top right corner of my screen. Anyway, this works great now both on my my iPhone and my MacBookPro. I am happy!!!!!
     
  9. eddiewouldcode macrumors newbie

    Joined:
    Jun 30, 2007
    #9
    I'm having the same problem, anyone got any fix? btw, my router is Belkin.

    My iphone recognizes my router and connects to it, the wifi icon displays at the top bar. But as soon as I use Safari, it would switch back to Edge. I look under the wifi section in iphone setting, DHCP has an ip of 169.254.253.199 instead of the usual 192.168.2.X

    any ideas??
     
  10. ljp macrumors newbie

    Joined:
    Jul 1, 2007
    #10
  11. blehpunk macrumors regular

    Joined:
    May 3, 2005
    #11
    we have 2 iphones and had the same problem with one of them. im using an airport base station, and i didnt have any password on it at all. so after reading this i added a wpa password and suddenly it works. so weird.
     
  12. rlowe44 macrumors newbie

    Joined:
    Dec 31, 2007
    #12
    Better to not use just WPA

    I was having the same problem with my WiFi, even though it was set to WPA. When I changed it to WPA-TKIP, it connected perfectly and remains connected. It was dropping the connection every 30 seconds until then.
    Rlowe44
     

Share This Page