WiFi not working again

Discussion in 'iPod touch' started by AnotherFanBoy, Sep 12, 2009.

  1. AnotherFanBoy macrumors regular

    Joined:
    Jul 5, 2009
    #1
    Hey everyone

    So I have an 8GB 2G Touch and it connects to the network, says it is connected but there is no WiFi symbol in the top left corner. Mail, Safari and any other internet related apps aren't connecting either. It's the same on every network I try to use.

    I upgraded to the latest firmware (3.1) but this happened to me before when I was on 2.2. I took it into the Apple Store and after the genius looked at it, he swapped it for a new one.

    I have tried restoring, forgetting and reconnecting and turning off and on. But nothing seems to work.

    It's still within its 1 year warranty and I would like to take it in to the store and get it replaced again, but I was going to buy a new 64GB Touch and give this one to my little brother, but if they would do it, I would like to swap this for the 64GB and pay the difference. Only problem is, I'm a little worried the Genius will think I'm trying to con him. So if possible I'd like to fix it myself.

    Any ideas are appreciated.

    Thanks
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    I doubt they will let you swap it for a new one. Just get it replaced at the genius bar, and then either buy a 64gb, or sell it, and use the money to buy the new one. But I'm sure your brother would appreciate your "old" iPod. :)
     

Share This Page