WiFi not working at all???

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Kurt Hustle, Jul 16, 2007.

  1. Kurt Hustle macrumors newbie

    Joined:
    Jul 16, 2007
    #1
    Hey guys sorry if this has been addressed a ton of times, very new here and I tried looking around for an answer as best I could.

    Yesterday I received a new iPhone from my local Apple store after an appointment at genius bar and complaining about my battery life. They were not able to activate there..due to activations being down at the moment. Later on I activated and synced the phone. But one thing I notice is that my WiFi feature does not work at all...after entering my wep key the phone tells me "unable to join the network (name of network)" ...I've also tried connecting to local unsecured networks and I receive the same message. It has NOT connected once.

    My question is...is this fixable bymyself , or is another trip to Apple for my 3rd iPhone necessary? Thanks in advance.
     
  2. Resevdog macrumors regular

    Joined:
    Jul 5, 2007
    #2
    common problem

    Sounds like your in the same group with a bunch of other users. On the plus side, ita can be a very simple fix if it is the problem I think it is.

    You stated you are using WEP. Go under settings and select wifi. When the list populates with your connection, select it to go into the settings. Now scroll down into the advanced settings. Select the box with Password and it should bring up two choices: passphrase or ASCII/Hex. Odds are you have the wrong type selected. Switch to the other and save it. If you type a password, you have passphrase. If your security code is like 02xx0e09...then you are using ASCII/Hex.

    Try connecting now.
     
  3. Kurt Hustle thread starter macrumors newbie

    Joined:
    Jul 16, 2007
    #3
    Thank you Resevdog for the quick response. While I did have the wrong box for my password selected (I was on password while I needed to be on Hex) It still would not connect to my WiFi, like I said I also have tried to connect to multiple local unsecured networks but still no luck. I was actually able to connect to a unsecured network for a split second before it went back to edge and the menu popped up asking me to select a WiFi network to join.

    At this point is it safe to say the problem is the iPhone? Should I attempt a restore or just go back to Apple? My voice quality is also tremendously low and static filled. I do still have the original film over the screen (waiting for my skin from bestskinsever to come in) But even with taking that off I cant see it being much of an improvement. Thanks again for the response.
     
  4. Resevdog macrumors regular

    Joined:
    Jul 5, 2007
    #4
    unusual...

    well, the only other thing I can guess is that your passkey is being entered incorrectly. I know I entered mine in a couple times wrong since I didn't pay attention to the keypresses. Make sure you watch which characters popup under your tap when your typing. Also double check your 1's and I's and l's and o's and 0's. But the fact you can't connect to open networks is strange.

    I would suggest starting your connections fresh. Power down your wireless router. Erase the connection on your phone. Powerup the router, then try to add the connection on the phone. Sometimes this works.

    Finally, I'm assuming you're using a b/g router and not draft n. Draft N doesn't seem to be supported by the iPhone yet.

    Well, you've done it. You've totally exhausted my knowledge library.

    As for the film on the screen...take it off. The screen is probably the toughest part of the phone. The thing is incredibly scratch resistant.
     
  5. Scottgfx macrumors 6502

    Joined:
    Feb 26, 2002
    Location:
    Fort Myers, FL
    #5
    I think this may be just more bad luck. I have a coworker who's first iPhone's WiFi did not work. He had to return it and get another. I got mine on the "day after"... you know, the day after iDay, ;) but I've not not had any problems.

    I hope you get yours sorted out.
     
  6. n8236 macrumors 65816

    Joined:
    Mar 1, 2006
    #6
    If you have already tried "WEP" and "WEP hex or ASCII," try going to back to the list of available networks and choose "Other..."

    There you can choose from two more pw types, "WPA" and "WPA2."

    Update: Use 64bit instead of 128bit security. No more password incorrect messages.
     
  7. G4R2 macrumors 6502a

    Joined:
    Nov 29, 2006
    #7
    I posted this elsewhere for a similar problem. I had an issue with a Netgear Wirelss G router that my iPhone was unable to connect to. The glitch seems to have been on the router side. The router was set to connect on 802.11 g only. The way I got it to work, on a lark, was to set the router to connect on wireless b and g. On that setting the router connects to everything without a problem. But if it is set to 802.11 g only it has issues with some newer devices.

    So without knowing exactly why this might be the case I can only suggest toggling the wireless b and g settings to see if it helps.
     
  8. Kurt Hustle thread starter macrumors newbie

    Joined:
    Jul 16, 2007
    #8
    ^^ Thanks to all who provided insight and offered help. I'm afraid the problem was I'm a moron lol. I forgot my router was set for Mac address filtering. After switching my iPhone at the apple store, forgot to put the new phone on there. It seems to be working like a charm now, still doesn't explain why I couldn't connect to unsecured networks.
     

Share This Page