Wifi not working on MBA

Discussion in 'MacBook Air' started by EmmaLouise, May 29, 2012.

  1. EmmaLouise macrumors member

    Joined:
    Aug 2, 2010
    Location:
    Andalucia, Spain
    #1
    Hi,

    I'm at home..... in front of my iMac, with an old windows laptop downstairs, a kindle fire and an ipad in my office and all of them will connect to my home internet.....

    Apart from my new MBA.... it'll connect everywhere else when I'm out and about..... I just cannot get it to connect at home!

    Any ideas?

    ps, I may have all these things but am not very technically minded - so plain English answers please :)
     
  2. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #2
    If all those other devices will connect but your MBA won't, then let's try these basic troubleshooting steps:

    1. Restart your MBA.
    2. Try turning your Airport off then on again with the icon in the upper right corner.
    3. Try "forgetting" your base station and rejoining it again. (Use System Preferences --> Network --> Airport --> Advanced... button --> Select your base station --> Press the minus (-) button --> OK --> Select your base station from the drop-down list box)
    4. Power off your base station, power it back on again, and try step 3 again.

    If those steps don't work, just write back.
     
  3. larryleveen macrumors newbie

    Joined:
    Oct 12, 2011
    #3
    Some MBAs, like mine, have trouble connecting with WiFi or experience very slow wifi connections when Bluetooth is turned on. It makes Bluetooth essentially unusable for me and many others -- there are extensive threads about this on Apple's Support site (and lots of angry people including me!):

    https://discussions.apple.com/thread/2730693?start=0&tstart=0

    The fact that you have problems connecting at home to WiFi but not when you are away from home might explain this -- when not at home, you might not be using Bluetooth devices, but at home you do (but cannot connect to WiFi as a result).

    Try turning off Bluetooth -- even if you are not using WiFi devices (the menu to the left of your WiFi menu).

    Hoping for a fix to this in the next OS upgrade :-(
     
  4. EmmaLouise thread starter macrumors member

    Joined:
    Aug 2, 2010
    Location:
    Andalucia, Spain
    #4
    hi,

    thank you both for replying..

    I've tried all suggestions and still nothing!

    It is very frustrating and I don't know what more to do about it....

    :-(
     
  5. ZirkMan macrumors newbie

    Joined:
    Jul 24, 2011
    Location:
    Eternal now.
    #5
    It's Lion

    It's Lion's fault.
    I have the same problem from time to time but only in OS X.
    Wifi in my Bootcamp Windows 7 on the same machine never has the problem.

    Try to update the OS X to the latest version and if that does not help try to turn off and on the wifi several times until it sees the networks and connects.
     
  6. EmmaLouise thread starter macrumors member

    Joined:
    Aug 2, 2010
    Location:
    Andalucia, Spain
    #6
    Hello,

    I realised that I could ring Applecare as I've only had the MBA for 2 months...

    A very intelligent young man on the phone guided me through many different trouble shooting options..... in the end it was a keychain issue.... once we had deleted the keychain for my home wifi and built it again...... it worked!

    Congrats that man!

    Thanks everyone x
     

Share This Page