WIFI not working?

Discussion in 'iPhone' started by Chucko, Jul 17, 2007.

  1. Chucko macrumors newbie

    Joined:
    Jun 14, 2007
    #1
    Suddenly today when I am in an WIFI area, such as my home the little [E] stays up in the corner even though under options it shows my wifi network connected. I know it's not using the wifi because of the up/down speeds. I've tested this in 3 different spots and in all 3 it shows the wifi, but the [E] stays in the corner and the speeds are EDGE speeds.
     
  2. sJv macrumors regular

    Joined:
    Jul 11, 2007
    Location:
    Sierra Foothills, CA
    #2
    I see the same thing - I just replied to this thread with what I do to get it to work.

    http://forums.macrumors.com/showthread.php?t=330995

    I find it odd that it didn't do it initially, but just recently, and now there are two other folks (at least) who are having the same problem.

    -steve
     
  3. Chucko thread starter macrumors newbie

    Joined:
    Jun 14, 2007
    #3
    Tried your suggestion but still didn't work....grrrrrr
     
  4. sJv macrumors regular

    Joined:
    Jul 11, 2007
    Location:
    Sierra Foothills, CA
    #4
    The Apple support forum has a number of threads on this issue. One person put the iPhone in Airline mode for a few minutes, then back to normal and it worked. I haven't tried that combo. I find that eventually it works again. Interesting bug! I think I've even had it to go WiFi mode when I take a phone call, only to have it go back to edge when the call is over!

    -steve
     
  5. n8236 macrumors 65816

    Joined:
    Mar 1, 2006
    #5
    If you have already tried "WEP" and "WEP hex or ASCII," try going to back to the list of available networks and choose "Other..."

    There you can choose from two more pw types, "WPA" and "WPA2."

    Update: Use 64bit instead of 128bit security. No more password incorrect messages.
     
  6. semperfimarine2 macrumors regular

    semperfimarine2

    Joined:
    Apr 2, 2007
    Location:
    Austin Texas
    #6
    I was also having this problem with my current home router and I was trying everything people had listed. Then I finally wised up and unplugged my router, waited a couple of minutes, plugged it back in....and voila, my iPhone was picking up my home router. If you all still having problems with your wi-fi, I suggest you try this.:apple:
     
  7. Passante macrumors 6502a

    Passante

    Joined:
    Apr 16, 2004
    Location:
    on the sofa
    #7
    While this may not help you I ran into the opposite situation at an Apple store. All the iPhones were on wifi and I tried to set one to edge to see how slow the connection was. Three of the four iPhones I tried to switched to edge refused to connect to the edge network! Very strange.
     
  8. n8236 macrumors 65816

    Joined:
    Mar 1, 2006
    #8
    I have had wifi connectivity w/ 128 encryption, try 64bit.

    Also, try manually entering the SSID of the network, then change the pw type. you get two other selections tat way.
     
  9. sJv macrumors regular

    Joined:
    Jul 11, 2007
    Location:
    Sierra Foothills, CA
    #9
    In this case, it isn't a matter of improperly setting up the link. The link is set up and has been working for days, then all of a sudden, it can no longer connect. It shows it as connected in the WiFi settings, but the IP address is not filled in or not correct (the default IP address is shown in this case). It is connected to edge instead. After filddling with things as I've stated above, it eventually will connect again. I see this as a bug in the network stack. The Apple support forums have a LOT of people with the same problem.

    -steve
     
  10. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #10
    Is this just in one WiFi area or ALL WiFi areas? I had an issue where WiFi wouldn't connect automatically at home (even though I could go in an choose it under settings). Turns out the problem was there were two available WiFi networks with the name "linksys" and it couldn't figure it out. I just changed the name of my home network to something unique and it started working.
     

Share This Page